Open Bug 633300 Opened 9 years ago Updated 5 months ago

Tabs sometimes get teared off when selecting them

Categories

(Firefox :: Tabbed Browser, defect, major)

3.6 Branch
defect
Not set
major

Tracking

()

UNCONFIRMED

People

(Reporter: jules-misterbombastic, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 (BT-beachlife) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 (BT-beachlife) Firefox/3.6.13

If there are more than 1 tab opened an I switch between them firefox opens the tab I wanted to switch to in a new window. It happens not regularly. The tab which should be in front gets closed and firefox opens it in a new window. 

Reproducible: Always

Steps to Reproduce:
1.Opened 4 tabs
2.switched between tab 1 an tab 3
3. 
Actual Results:  
Happens every time but not at regular intervalls.

Expected Results:  
Firefox opens selected tab in a new window. Instead it should have switched to the tab without opening it in a new window.

 Reported to me by many Firefox-Users from Germany.
- using the Add-On Colourfull Tabs
Does that also happen in Safe Mode (http://support.mozilla.com/en-US/kb/Safe Mode)?
Version: unspecified → 3.6 Branch
(In reply to comment #1)
> Does that also happen in Safe Mode (http://support.mozilla.com/en-US/kb/Safe
> Mode)?

As far as it was possible for me to check that(because it doesn´t happen regularly)I can say that it doesn´t happen in the Safe Mode ;)
(In reply to comment #2)
> (In reply to comment #1)
> > Does that also happen in Safe Mode (http://support.mozilla.com/en-US/kb/Safe
> > Mode)?
> 
> As far as it was possible for me to check that(because it doesn´t happen
> regularly)I can say that it doesn´t happen in the Safe Mode ;)

I´ve tried a bit and now I can say it happens in Safe Mode too:/
How do you switch between tabs? Are you using the mouse? Do you drag the tab a bit when you select it? Could be the reason why a tear-off action gets started.
Also please install the latest beta of Firefox 4. This could have been already fixed.

http://www.mozilla.com/en-US/firefox/all-beta.html
This would have been my next step if my problem has been still existing ;)
(In reply to comment #4)
> How do you switch between tabs? Are you using the mouse? Do you drag the tab a
> bit when you select it? Could be the reason why a tear-off action gets started.

(In reply to comment #4)
> How do you switch between tabs? Are you using the mouse? Do you drag the tab a
> bit when you select it? Could be the reason why a tear-off action gets started.

I´m just clicking at the tab. I´m not dragging it;)
(In reply to comment #6)
> This would have been my next step if my problem has been still existing ;)

I´ll install Firefox 4 beta now an then I´ll report to you wether it happens there too;)
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
I'm working with firefox 4.0.1 and it happens to me too. Firefox opens the tab I click on in a new window if I have more than one tab open.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(In reply to comment #9)
> I'm working with firefox 4.0.1 and it happens to me too. Firefox opens the
> tab I click on in a new window if I have more than one tab open.

You´re right it also happens with firefox 4.0.1. I have updated mine too. How do I get this problem solved-.-
Version: 3.6 Branch → 4.0 Branch
OS: Windows XP → All
Hardware: x86 → All
Summary: If there are more than 1 tab opened firefox opens some tabs in a new window itself. → Tabs sometimes get teared off when selecting them
Version: 4.0 Branch → 3.6 Branch
Duplicate of this bug: 641805
Does it happen with an external mouse or with a touchpad?
Touchpad
external mouse
I can confirm this behaviour happens for me on Aurora 46.0a2 and I've been noticing it intermittently since at least some time in the 30s.

Given how my Firefox behaves under load, I suspect it might be something along these lines:

1. Mouse button pressed and released over a tab
2. Press event is handled
3. While the handlers for the press event are running, the cursor moves off the tab
4. Release event is handled
5. Release handler uses the pointer's current position rather than the position stored in the event when deciding whether a tab drag occurred.

Still occurring in 66.0.5 and if anything, it's gotten worse. The tear off by drag function is oversensitive. Solutions: a) allow disable by user, B) allow delay (longer than normal mouseclick), C) increase range to drag -- please implement one or more of these. Only option now is to use an addon that disables move to new window altogether, throwing out baby with the bathwater.

(In reply to mfm773 from comment #16)

Still occurring in 66.0.5 and if anything, it's gotten worse. The tear off by drag function is oversensitive. Solutions: a) allow disable by user, B) allow delay (longer than normal mouseclick), C) increase range to drag -- please implement one or more of these. Only option now is to use an addon that disables move to new window altogether, throwing out baby with the bathwater.

Option C wouldn't help and option B probably wouldn't either.

Back in the Firefox 2 days, Firefox would drop keypresses if you typed too quickly while the system was bogging down, rather than allowing them to queue up. This appears to be a similar design problem with the mouse input where, when it gets around to processing the button release event, it takes the position of the cursor rather at the time the event is processed, rather than the position at the time it was emitted.

That means that "press, release, move" effectively gets mistakenly interpreted as "press, move, release" if Firefox gets delayed in processing the event.

(I know this because I've managed to get my Firefox so bogged down that I've managed to tear off tabs even when I click, wait a split second, and then move the mouse elsewhere when I've verified that the amount of movement during the click is well below the threshold Firefox uses to consider it a drag when not bogged down.)

You need to log in before you can comment on or make changes to this bug.