Create copy for new Get Involved landing page

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: davidwboswell, Assigned: tshahian)

Tracking

Details

(Reporter)

Description

8 years ago
Opening bug to track creating copy for a new Get Involved landing page on mozilla.org that will replace the current mozilla.org/contribute page.

Our goal is to have this page go live by the end of March.  Monique has already started work on designing this and is using the following copy in her initial mockups.

https://wiki.mozilla.org/Mozilla.org/Contribute/Get_Involved_Evolved/Landing_Page

This will likely go to webdev near the beginning of March.  

We could swap in new copy at any point in this process, but if the final copy is likely to be substantially different from the draft copy, would be good to get that to Monique during the design phase.

Comment 1

8 years ago
Tara, think we could give this to Matej when he's back from his trip?
(Assignee)

Comment 2

8 years ago
I think this would be great for Matej.  I'll make sure to loop him in after he gets back.
(Reporter)

Comment 3

8 years ago
We just found out that there may be a video we can use on this page, so that may change how we deal with the page copy and we may also want to tweak the copy in the video to make it fit better (since it wasn't created with this page in mind).

The video is at:

http://universalsubtitles.org/en/videos/lXdWMem6KVu8/info/Mozilla%20Firefox:%20A%20Different%20Kind%20of%20Browser/

Initial ideas about how we might want to tweak the video are at:

http://etherpad.mozilla.org:9000/what-is-mozilla-video

I'll follow up with Matej about this in IRC.
Here's some slightly tweaked and cleaned up copy for the Get Involved page:

HEADLINE: 
Build a better Web with us.

SUBHEAD: 
Mozilla is a fun, diverse community of people from around the world. You don’t have to be a C++ guru (or even know what that means!) to get involved. You just have to love the Web. Learn more

SIDEBAR:
Get In Touch
Want to get involved? Send us a note and we can get you started right away.

I've also made some suggestions about the video here: http://etherpad.mozilla.org:9000/what-is-mozilla-video
(Reporter)

Comment 5

8 years ago
Updating bug based on conversation about video with Mary, Ryan, Brett and David.

* It is possible to make changes to the video, although we need to keep the scope fairly modest since there is limited time available for more edits.

* There was agreement about changing the way we talk about people's titles and this can be done with small tweaks.

* We discussed several different ways to structure the ending to have it fit in the page.  For next steps here Brett is going to update the etherpad with notes and then we can ask Matej to craft the specific copy changes we'll ask the editor to make.
I modified the etherpad based on our conversation:
http://etherpad.mozilla.org:9000/what-is-mozilla-video

Remember - don't add new lines, just edit the existing ones there.

Thanks, all!
BG
Could I have a look at the images that are going to accompany each copy point and maybe chat with someone to get a little clearer direction on each?

And what's the timing on this?
To clarify, it's really the Drumbeat one I'm unclear on. The rest, I think, are pretty straightforward. Thanks!
Sure, Matej - why don't you work on the copy, then once its solid, I can set up a meeting with yourself and our editor to discuss what we'd like in all the frames.  Make sense?  In the meantime you could come up with some suggestions, source photos, etc.  That would be helpful.

Cheers!
Brett
(Reporter)

Comment 10

8 years ago
In terms of timing we have some flexibility since the page can go live without the video since the rotating images work fine for now.  

The main factor may be the editor's schedule -- I'm not sure if there's a window where we need to get the edits sent in?
(Reporter)

Comment 11

8 years ago
Note, I've updated the mozilla.org/contribute page with Matej's edits in comment #4.
I noticed that the copy on the Get Involved page is almost — but not quite — the same as what's on the new Join Mozilla campaign: "Build a better Web with us." vs. "Help us build a better Web."

Given how similar they are, I'd suggest either using the Join Mozilla line on both, or (if we'd rather separate the two) creating something different for Get Involved.

Thoughts?
(Reporter)

Comment 13

8 years ago
Re comment #12, good point.  Get Involved and Join Mozilla are obviously similar but there are differences (Get Involved is an umbrella that covers all contribution opportunities vs. Join being a specific way to contribute).

Maybe just going with 'Get Involved with Mozilla' for the page title?  That corresponds to the text of the link to the page in the global nav and is general enough to cover everything on the page.  Open to other ideas.
(In reply to comment #13)
> Re comment #12, good point.  Get Involved and Join Mozilla are obviously
> similar but there are differences (Get Involved is an umbrella that covers all
> contribution opportunities vs. Join being a specific way to contribute).
> 
> Maybe just going with 'Get Involved with Mozilla' for the page title?  That
> corresponds to the text of the link to the page in the global nav and is
> general enough to cover everything on the page.  Open to other ideas.

Given that it is an umbrella, I think something straightforward like "Get Involved with Mozilla" works really well, but also happy to come up with other options if you'd like.
(Reporter)

Comment 15

8 years ago
I'll go with Get Involved with Mozilla for now and if you come up with a better alternative we can swap it in later.  Thanks.
I've updated the etherpad with new titles, copy and links to images:

http://etherpad.mozilla.org:9000/what-is-mozilla-video

Please have a look and share your thoughts.
Thanks, Matej.  This is clear, although - do you only want one image per screen? ie only the flickr photos you sent?

Cheers,
Brett
(In reply to comment #17)
> Thanks, Matej.  This is clear, although - do you only want one image per
> screen? ie only the flickr photos you sent?

That was my feeling. I thought they could be treated like the images at :27 and :47. I think it's cleaner to have one key visual to go along with each sentence, especially given that people will be viewing the video at a fairly small size.

Other thoughts?
Sounds good!  And easier :)

I'll talk this over with the editor.  This is very clear, so no need for another call.  We'll have something to proof fairly soon.

Cheers!
BG
(Reporter)

Comment 20

8 years ago
Thanks Matej and Brett for getting the edits in place.  Excited to get this on the page.
(Assignee)

Comment 21

8 years ago
Matej confirmed that we're done here.  Closing!  Thanks all!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.