Closed Bug 633447 Opened 9 years ago Closed 8 years ago

Crash [@ MWSBAR.DLL@0x474b7 ][@ MWSBAR.DLL@0x49d87 ][@ MWSBAR.DLL@0x4a647 ][@ MWSBAR.DLL@0x46d27 ][@ MWSBAR.DLL@0x2589f ][@ MWSBAR.DLL@0x28a09 ][@ MWSBAR.DLL@0x256dd ][@ MWSBAR.DLL@0x25bb5 ] with MyWebSearch (software 2.3.78.2 and below, extension 1.1)

Categories

(Toolkit :: Blocklist Policy Requests, defect, critical)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- -
blocking1.9.2 --- -

People

(Reporter: scoobidiver, Assigned: kev)

References

Details

(Keywords: crash, Whiteboard: [softblocker])

Crash Data

It is #44 top crasher in 4.0b11.
Extension correlations give:
100% (53/53) vs.   2% (614/25018) m3ffxtbr@mywebsearch.com (1.1)

Signature	MWSBAR.DLL@0x474b7
UUID	91d8a63f-d49e-4baa-9931-9b1242110209
Time 	2011-02-09 12:57:25.314495
Uptime	93
Last Crash	103 seconds before submission
Install Age	93 seconds since version was first installed.
Product	Firefox
Version	4.0b11
Build ID	20110203141415
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 16 model 6 stepping 2
Crash Reason	EXCEPTION_STACK_OVERFLOW
Crash Address	0x78e74b7
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9553, AdapterDriverVersion: 8.632.0.0

Frame 	Module 	Signature [Expand] 	Source
0 	MWSBAR.DLL 	MWSBAR.DLL@0x474b7 	
1 	MWSBAR.DLL 	MWSBAR.DLL@0x67a8 	
2 	M3PLUGIN.DLL 	M3PLUGIN.DLL@0x38a2 	
3 	M3PLUGIN.DLL 	M3PLUGIN.DLL@0x3bca 	
4 	xul.dll 	CallNPMethodInternal 	modules/plugin/base/src/nsJSNPRuntime.cpp:1489
5 	xul.dll 	CallNPMethod 	modules/plugin/base/src/nsJSNPRuntime.cpp:1542
6 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4784
7 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:661
8 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
9 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2188
10 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4784
11 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:661
12 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
13 	mozjs.dll 	js::InvokeSessionGuard::invoke 	js/src/jsinterpinlines.h:594
14 	mozjs.dll 	array_extra 	js/src/jsarray.cpp:2825
15 	mozjs.dll 	array_forEach 	js/src/jsarray.cpp:2882
16 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4784
17 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:661
18 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
19 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2188
20 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4784
21 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:661
22 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
23 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:862
24 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5053
25 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1701
26 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:588
27 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
28 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
29 	xul.dll 	nsBrowserStatusFilter::OnStateChange 	toolkit/components/statusfilter/nsBrowserStatusFilter.cpp:183
30 	xul.dll 	nsDocLoader::FireOnStateChange 	uriloader/base/nsDocLoader.cpp:1334
31 	xul.dll 	nsDocLoader::FireOnStateChange 	uriloader/base/nsDocLoader.cpp:1341
32 	xul.dll 	nsDocLoader::doStopURLLoad 	uriloader/base/nsDocLoader.cpp:907
33 	xul.dll 	nsDocLoader::OnStopRequest 	uriloader/base/nsDocLoader.cpp:691
34 	xul.dll 	nsLoadGroup::RemoveRequest 	netwerk/base/src/nsLoadGroup.cpp:680
35 	xul.dll 	xul.dll@0xb3107b 	
36 	xul.dll 	imgRequestProxy::OnStopRequest 	modules/libpr0n/src/imgRequestProxy.cpp:726

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=MWSBAR.DLL%400x474b7
With combined signatures, it is a virtual #14 top crasher.
blocking2.0: --- → ?
Summary: Crash [@ MWSBAR.DLL@0x474b7 ] with MyWebSearch 1.1 → Crash [@ MWSBAR.DLL@0x474b7 ][@ MWSBAR.DLL@0x49d87 ][@ MWSBAR.DLL@0x4a647 ][@ MWSBAR.DLL@0x46d27 ] with MyWebSearch 1.1
Component: Extension Compatibility → Blocklisting
Product: Firefox → addons.mozilla.org
QA Contact: extension.compatibility → blocklisting
Version: Trunk → unspecified
Does anyone know why we aren't running this plugin OOPP, which is the default?
Assignee: nobody → kev
blocking2.0: ? → final+
Whiteboard: [softblocker]
Depends on: 523784
This is another IAC property, so it's probably similar to things like the Ask.com toolbar extension, and won't get updated regularly. It'll probably need a block to resolve, as a lot of the installers that put this on people's systems are fire-and-forget. I'll ask my contacts at Ask if this SW is maintained any more by Mindspark. Either way, if it's a significant crasher, it should probably make its way to the blocklist.
Now virtual #7 in 4.0b11 and #4 top crasher in 3.6.13.
blocking1.9.2: --- → ?
OS: Windows 7 → All
Summary: Crash [@ MWSBAR.DLL@0x474b7 ][@ MWSBAR.DLL@0x49d87 ][@ MWSBAR.DLL@0x4a647 ][@ MWSBAR.DLL@0x46d27 ] with MyWebSearch 1.1 → Crash [@ MWSBAR.DLL@0x474b7 ][@ MWSBAR.DLL@0x49d87 ][@ MWSBAR.DLL@0x4a647 ][@ MWSBAR.DLL@0x46d27 ][@ MWSBAR.DLL@0x2589f ][@ MWSBAR.DLL@0x28a09 ][@ MWSBAR.DLL@0x256dd ][@ MWSBAR.DLL@0x25bb5 ] with MyWebSearch 1.1
So, colour me embarassed, as I was totally wrong here. Mindspark was very responsive, and is aware of the bug and what needs to be done. They're working on a fix now, and hope to deploy it as soon as they can. They do have the capability to update, and are hopeful they can push a change reasonably quickly. They'll have an update tomorrow on a fix and expected uptake rates. I'll update the bug then, and have asked them to participate here as well. More to come.
blocking1.9.2: ? → -
A lot of anti-spyware softwares detect it as a spyware:
http://en.wikipedia.org/wiki/MyWeb_Searchbar
Moreover, it is not referenced by https://addons.mozilla.org.

What is the goal of add-on blocklisting?
1. Remove add-on top crashers.
2. Remove spywares.
If only 1., let's wait the fix from Mindspark.
If 2., block-list it.
(In reply to comment #5)
> They'll have an update tomorrow on a fix and expected uptake rates.
> I'll update the bug then, and have asked them to participate here as well. More
> to come.

It's been 2 weeks -- have they said anything?
MWSBAR.DLL seems to be behind at least part of the general instability between 4.0betas and facebook apps/Frontierville/farmville.

we should probably change this to hardblocker, at least until we can assess how much of the facebook app crashiness is attributable to MWS

We are consistently seeing daily comments like this.

MWSBAR.DLL@0x474b7
        It always crashes when I try to send gift requests in a Facebook game called Frontierville!
        http://static.ak.facebook.com/xd_receiver_v0.4.php?r=1298439629#%7B%22id%22%3A3%2C%22h%22%3A%22iframeOuterServer%22%2C%22sid%22%3A%220.729%22%2C%22t%22%3A0%7D%5B3%2C%22iframeInnerClient%22%2C%22setCanvasHeight%22%2C%221053px%22%2Cfalse%5D
        Firefox 4.0b12 Windows NT 5.2.3790 Service Pack 2 4.0b12
         633447

MWSBAR.DLL@0x49d87
        I keep getting this message, everytime I go onto Facebook this does this.
        http://www.facebook.com/connect/uiserver.php?locale=en_US
        Firefox 4.0b12 Windows NT 6.1.7600 4.0b12
         633447

MWSBAR.DLL@0x49d87
        it did it again..closes when on farmville
        http://static.ak.connect.facebook.com/xd_receiver_v0.4.php?r=1298920497#%7B%22id%22%3A4%2C%22h%22%3A%22iframeOuterServer%22%2C%22sid%22%3A%220.176%22%2C%22t%22%3A0%7D%5B4%2C%22iframeInnerClient%22%2C%22setCanvasHeight%22%2C%221057px%22%2Cfalse%5D
        Firefox 4.0b12 Windows NT 6.1.7600 4.0b12
         633447
Blocks: 637512
Resetting nom for the triage meeting.
blocking2.0: final+ → ?
chofmann asked me to try to reproduce this. I installed the toolbar and confirmed the version, and have been performing different operations in FrontierVille such as sending gift requests but so far no crash. I am testing in a WinXP VM. Will try a few other machines.
We can blocklist this after we release; keep working the bug, and push hard on getting the blocklist updated.
blocking2.0: ? → -
Will call them now. AFAIK, they have released a new version to address the issues. Hit me up in #planning when you get to it in today's triage.
Just got off the phone with the product team, and they understand we may still blocklist, but are having problems replicating errors. They'd like some assistance from the QA/CrashKill team; who can I do an intro with?
If we have a privacy agreement, I can give them a minidump of a crash.
Or if they want to give me PDBs, I can give them real stacks and other data.
The MyWebSearch extension version is always 1.1. Anyway, 4.0b12 correlations by module version give:
  MWSBAR.DLL@0x4a647|EXCEPTION_STACK_OVERFLOW (293 crashes)
    100% (293/293) vs.   2% (1809/75882) MWSBAR.DLL
        100% (293/293) vs.   1% (678/75882) 2.3.78.2
  MWSBAR.DLL@0x49d87|EXCEPTION_STACK_OVERFLOW (234 crashes)
    100% (234/234) vs.   2% (1809/75882) MWSBAR.DLL
        100% (234/234) vs.   1% (498/75882) 2.3.76.6
  MWSBAR.DLL@0x474b7|EXCEPTION_STACK_OVERFLOW (181 crashes)
    100% (181/181) vs.   2% (1809/75882) MWSBAR.DLL
        100% (181/181) vs.   1% (402/75882) 2.3.70.1
  MWSBAR.DLL@0x46d27|EXCEPTION_STACK_OVERFLOW (111 crashes)
    100% (111/111) vs.   2% (1809/75882) MWSBAR.DLL
         30% (33/111) vs.   0% (70/75882) 2.3.69.8
         70% (78/111) vs.   0% (110/75882) 2.3.69.9
  MWSBAR.DLL@0x44207|EXCEPTION_STACK_OVERFLOW (13 crashes)
    100% (13/13) vs.   2% (1809/75882) MWSBAR.DLL
        100% (13/13) vs.   0% (23/75882) 2.3.67.1
  MWSBAR.DLL@0x4a627|EXCEPTION_STACK_OVERFLOW (10 crashes)
        100% (10/10) vs.   0% (11/75882) 2.3.78.0

The latest MyWebSearch version is 2.3.78.2.
Summary: Crash [@ MWSBAR.DLL@0x474b7 ][@ MWSBAR.DLL@0x49d87 ][@ MWSBAR.DLL@0x4a647 ][@ MWSBAR.DLL@0x46d27 ][@ MWSBAR.DLL@0x2589f ][@ MWSBAR.DLL@0x28a09 ][@ MWSBAR.DLL@0x256dd ][@ MWSBAR.DLL@0x25bb5 ] with MyWebSearch 1.1 → Crash [@ MWSBAR.DLL@0x474b7 ][@ MWSBAR.DLL@0x49d87 ][@ MWSBAR.DLL@0x4a647 ][@ MWSBAR.DLL@0x46d27 ][@ MWSBAR.DLL@0x2589f ][@ MWSBAR.DLL@0x28a09 ][@ MWSBAR.DLL@0x256dd ][@ MWSBAR.DLL@0x25bb5 ] with MyWebSearch (software 2.3.78.2 and below, extension 1.1)
MWS team reported back that they had addressed, and I think crash data correlated that. Closing off; reopen if that's not the case.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Crash Signature: [@ MWSBAR.DLL@0x474b7 ] [@ MWSBAR.DLL@0x49d87 ] [@ MWSBAR.DLL@0x4a647 ] [@ MWSBAR.DLL@0x46d27 ] [@ MWSBAR.DLL@0x2589f ] [@ MWSBAR.DLL@0x28a09 ] [@ MWSBAR.DLL@0x256dd ] [@ MWSBAR.DLL@0x25bb5 ]
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.