Closed Bug 633457 Opened 11 years ago Closed 11 years ago

Firefox hangs at startup

Categories

(Core :: General, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla2.0b12
Tracking Status
blocking2.0 --- final+

People

(Reporter: ginnchen+exoracle, Assigned: ginnchen+exoracle)

Details

(Keywords: hang, Whiteboard: [hardblocker][has patch])

Attachments

(2 files)

It's not 100% reproducible.
It happens if $HOME/.mozilla doesn't exist and memory is low (maybe).

I see this problem a lot with LiveCD on VirtualBox or VMWare.

Stack attached.
Stack?
Component: XPCOM → General
QA Contact: xpcom → general
Attached file hang stack
In lwp# 1, it is shutting down sCollectorThread. sCollectorRunner should have already been shutdown.

Why do we still have lwp# 3 ?
I believe the reason is
lwp# 1 did Shutdown() before lwp # 3 setting mRunning to TRUE.

i.e.

lwp# 1 returns from Shutdown() at
http://hg.mozilla.org/mozilla-central/file/1ed3464aaa92/xpcom/base/nsCycleCollector.cpp#l3372
then
lwp#3 starts running at
http://hg.mozilla.org/mozilla-central/file/1ed3464aaa92/xpcom/base/nsCycleCollector.cpp#l3302
blocking2.0: --- → ?
Attached patch patchSplinter Review
Assignee: nobody → ginn.chen
Status: NEW → ASSIGNED
Attachment #511913 - Flags: review?(dbaron)
Yeah, this looks like a recent regression from the cycle-collector threading stuff.
blocking2.0: ? → final+
Whiteboard: [hardblocker]
Hm, why are we shutting down so early?

Patch looks good btw.
Whiteboard: [hardblocker] → [hardblocker][has patch]
(In reply to comment #7)
> Hm, why are we shutting down so early?

Because we're restarting.
Does this bug only affect OpenSolaris?
In theory, it affects all platforms.
It is a race condition.
(In reply to comment #8)
> (In reply to comment #7)
> > Hm, why are we shutting down so early?
> 
> Because we're restarting.

Huh, I thought we got rid of all that restart-on-startup stuff...
Ginn, I'd be happy to review this, but can you attach a patch with -P and a little more context? 'diff -U8 -P' is what i usually use.
OS: OpenSolaris → Linux
Attachment #511913 - Flags: review?(peterv)
Attachment #511913 - Flags: review?(dbaron)
Attachment #511913 - Flags: review?(bent.mozilla)
Comment on attachment 511913 [details] [diff] [review]
patch

This looks fine to me! Thanks.
Attachment #511913 - Flags: review?(bent.mozilla) → review+
(In reply to comment #12)
> Ginn, I'd be happy to review this, but can you attach a patch with -P and a
> little more context? 'diff -U8 -P' is what i usually use.

Sorry, I made the patch in VM so I missed my .hgrc.
OS: Linux → Windows CE
Comment on attachment 511913 [details] [diff] [review]
patch

I think dbaron wanted bent||peterv, rather than bent&&peterv, so clearing other review req.  I'll push this soon.
Attachment #511913 - Flags: review?(peterv)
http://hg.mozilla.org/mozilla-central/rev/afba7603a946
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Windows CE → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b12
You need to log in before you can comment on or make changes to this bug.