Closed Bug 633459 Opened 9 years ago Closed 9 years ago

Invoke creation callback on JSFunction scripts

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: sfink, Unassigned)

Details

(Whiteboard: [firebug-p2][fixed-in-tracemonkey])

Attachments

(1 file)

While working on bug 633016, I discovered that some scripts never trigger js_CallNewScriptHook(), although they *do* call js_CallDestroyScriptHook().

Although this appears to be harmless for JSD, it also means that these scripts are not visible to the debugger when they should be. If it weren't so late, I'd search for a known problem with undebuggable scripts.
Attachment #511659 - Flags: review?(lw) → review+
This may have been the cause for ?
http://code.google.com/p/fbug/issues/detail?id=1318
Whiteboard: [firebug-p2]
http://hg.mozilla.org/tracemonkey/rev/54e4a8c93708
Whiteboard: [firebug-p2] → [firebug-p2][fixed-in-tracemonkey]
http://hg.mozilla.org/mozilla-central/rev/54e4a8c93708
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.