Closed Bug 633511 Opened 9 years ago Closed 9 years ago

WebGL broken with D2D [@ gfxASurface::GetContentType()]

Categories

(Core :: Graphics, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: bugzilla, Assigned: bas.schouten)

References

()

Details

(Keywords: crash, regression, Whiteboard: [hardblocker][has patch])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-90743bfe-6d57-42af-b14a-c7adf2110211 .
============================================================= 

Steps to reproduce
1. visit http://web.chemdoodle.com/tutorial/3d-structure-canvases/transformer3d-canvas

Graphic card info:
        Adapter Description
        ATI Mobility Radeon HD 3400 Series

        Vendor ID
        1002

        Device ID
        95c4

        Adapter RAM
        256

        Adapter Drivers
        atiu9p64.dll atiuxp64 atiu9pag atiuxpag atiumdva atiumd6a atitmm64

        Driver Version
        8.752.4.0

        Driver Date
        10-22-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7600.20781, font cache n/a)

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU Accelerated Windows
        1/1 Direct3D 10
4.0b12pre/20110210: works
4.0b12pre/20110211: crashes

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=199cb6282554&tochange=1ed3464aaa92
Component: General → Graphics
Keywords: regression
OS: Windows NT → Windows 7
Product: Firefox → Core
QA Contact: general → thebes
blocking2.0: --- → ?
Looks like a null-deref regression from bug 628173 ?
Blocks: 628173
Assignee: nobody → bas.schouten
We regressed this on a mostly cosmetic change. we should be able to back it out if need be.
blocking2.0: ? → final+
Whiteboard: [hardblocker]
I messed up and did content type in the wrong place (where it got a shared WebGL surface rather than a cairo surface). This fixes that.

This blocks beta as it essentially makes WebGL not work on D3D10 at all.
Attachment #511841 - Flags: review?(jmuizelaar)
Requesting blocking beta for proper tracking.
blocking2.0: final+ → ?
Attachment #511841 - Flags: review?(jmuizelaar) → review+
blocking2.0: ? → betaN+
Summary: WebGL demo crashes [@ gfxASurface::GetContentType()] → WebGL broken with D2D [@ gfxASurface::GetContentType()]
meta question -- how did this not turn webgl tests red?  do we not have any machines that run both d3d10 + d2d + webgl tests?  (which will, I suspect, be a pretty common combination!)
(In reply to comment #6)
> meta question -- how did this not turn webgl tests red?  do we not have any
> machines that run both d3d10 + d2d + webgl tests?  (which will, I suspect, be a
> pretty common combination!)

This occured only when using ANGLE(D3D9)/D3D10 interop. This is disabled on the test machines currently. Jeff created a bug to change this.
Whiteboard: [hardblocker] → [hardblocker][has patch]
http://hg.mozilla.org/mozilla-central/rev/d6f1b1a06eb8
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified fixed.
Status: RESOLVED → VERIFIED
Crash Signature: [@ gfxASurface::GetContentType()]
You need to log in before you can comment on or make changes to this bug.