Status

()

RESOLVED DUPLICATE of bug 609856
8 years ago
8 years ago

People

(Reporter: bgdistance, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

96 bytes, text/html
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: 

Becouse it's not a English site, you may don't know what it is. but you can still test it by clicking check box.
http://news.titan007.com//analysis/404935.htm
First open this site using Chrome (or any other web browser), randomly click some check boxes, you will find the content changes by your each click, then switch to Firefox and do the same,nothing changes.

Reproducible: Always
Confirming. The Web Console is flooded with messages like this:

[18:12:16.071] Element referenced by ID/NAME in the global scope. Use W3C standard document.getElementById() instead. @ http://img2.bet007.com/js/analysis_ad.js:8

Not sure if that's the problem though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 511769 [details]
Test case

This alerts "undefined" in FF4, "[object HTMLDivElement]" in Chrome...
I don't think this is a JS bug. CC'ing some people who might know.

Updated

8 years ago
Assignee: general → nobody
Component: JavaScript Engine → DOM
QA Contact: general → general
Created attachment 511773 [details]
Test case

Reduced to this:

<div id="test">
  <input type="checkbox" onclick="alert(this.parentElement)">Check me!
</div>
Attachment #511769 - Attachment is obsolete: true
parentElement isn't part of the W3C DOM.  Is this an IE-ism webkit copied?
Hm this looks like a duplicate of bug 609856, which says it's standardized now?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 609856

Comment 7

8 years ago
(In reply to comment #6)
> Hm this looks like a duplicate of bug 609856, which says it's standardized now?

No it doesn't. It basically says that .parentElement may be standardized once Web DOM core stabilizes.
The question is whether we should be talking to this site in the meantime, since there are no immediate plans to implement parentElement and it's not clear whether it will stay in Web DOM core.
So undup and make this a TE bug?

/be
Well, that's the question.  Is it worth spending TE resources on this, or do we plan to implement parentElement in the timeframe in which TE might work (several months at least).
I wouldn't be opposed to implementing parentElement for next release, at least assuming that the implementation is what you'd expect it to be and doesn't have a lot of weird quirks (this has happened with the most simple looking APIs in the past).

In that case it might not be worth the TE.
You need to log in before you can comment on or make changes to this bug.