FTP Hyperlink causes multiple dialogs to spawn

VERIFIED WORKSFORME

Status

()

Core
Networking: FTP
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Tony Gorman, Assigned: dougt)

Tracking

Trunk
mozilla0.9
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Clicking on the link in the test page causes Mozilla to start spawning multiple
save as dialogs. It doesn't matter if you dismiss the box, cancel it, save as or
open, dialogs keep spawning. The only way to stop them is to close the browser.
However, if you close the browser while any dialogs are still open, you get an
application error in mozilla.exe.

Further investigation established the bug is present on Linux.

The bug is only reproducible from the ftp site in the example link. Other ftp
sites (mozillas for example) do not exhibit this behaviour.

It appears from network analysis that the FTP server is choking on the request
and Mozilla tries again, ad infinitum.

Comment 1

17 years ago
ok, confirmed on mac as well, so marking OS=all.
I did a network trace and it seems the ftp server is choking on something and
mozilla keeps retrying.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 2

17 years ago
I don't know how relevant this is, but when I end task'd Mozilla after testing
the problem, I got this illegal operation on win 98

MOZILLA caused an invalid page fault in
module DOCSHELL.DLL at 018f:6011bb87.
Registers:
EAX=00200001 CS=018f EIP=6011bb87 EFLGS=00010297
EBX=01449190 SS=0197 ESP=0068f95c EBP=0068f96c
ECX=00000000 DS=0197 ESI=01430c10 FS=438f
EDX=0068fa40 ES=0197 EDI=01449190 GS=7577
Bytes at CS:EIP:
89 81 dc 00 00 00 33 c0 c2 04 00 56 8b f1 8b 86
Stack dump:
6011c9d8 00200001 00000000 0144f720 0068fa44 6099474f 01430c10 0068f9b4 00000007
60d59658 01449190 0068fa40 00004002 01449190 0144f720 60c92620 

Comment 3

17 years ago
That's right, I forgot to add that.  If you kill the window (to stop the dialogs
from constantly spawning), mozilla crashes shortly after.  I have a talkback
from that: TB23282256Z

Comment 4

17 years ago
updating compnent and owner.
Assignee: asa → dougt
Component: Browser-General → Networking: FTP
QA Contact: doronr → tever
(Assignee)

Comment 5

17 years ago
Works for me.  I could not reproduce this with today's build.  Please reopen if
this still occurs and provide your exact configuration.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 6

17 years ago
yeah, this is happening for me on WinNT4 build 2001-01-22-13-MTEST so I'm 
re-opening.

Doug, what configuration information do you need?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 7

17 years ago
tever, could you try this on today's trunk build?  What is a MTEST build?  
Keywords: nsbeta1
(Assignee)

Comment 8

17 years ago
This works for me with a tree pulled last night.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 9

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.