Window behavior for dragging bookmarks is crippled

RESOLVED DUPLICATE of bug 419911

Status

()

defect
RESOLVED DUPLICATE of bug 419911
9 years ago
9 years ago

People

(Reporter: brmpfi, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre

Selecting a bookmark from the bookmark dropdown menu and dragging it is a frustrating experience. The problem is twofold:

1. If i drag a bookmark up or down the list, i am given a 10px high bar to land on in order to get the list to move up or down. If i overshoot the bar then the list disappears and im left holding a bookmark, to which i can either go to the bookmarked page, or carefully hold the mouse while dragging it up to the toolbar to try again. 

2. Even more frustrating is trying to place a bookmark into a folder or subfolder. While it is easy to drag it over the folder and let it be placed last on the list, oftentimes i want to drop it in a certain place, which means i have to carefully hold the mouse down and drag it horizontally across the folder "bar" in order to get into the folder itself, where my natural inclination is to go diagonally across to the location i want to drop it, which causes the folder cancel out, and subsequently, now being over its perimeter, the bookmark dropdown itself. It is the same for accessing subfolders, except now there are more windows to cancel out should i move a pixel over the narrow channel i am given to traverse. 

Whats odd about this behavior is that when browsing the bookmark dropdown menu and its folders, its not there. The rather simple use of timeouts on folders and a permanent select of the dropdown menu, regardless of mouse position, solves all these problems. Now why is it that when dragging a bookmark the user should not have these features?

Reproducible: Always
Version: unspecified → Trunk
Severity: enhancement → normal
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419911
You need to log in before you can comment on or make changes to this bug.