Need 48x48 and 64x64 sized versions of the default add-on icons

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
8 years ago
a year ago

People

(Reporter: fligtar, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
Created attachment 511863 [details]
screenshot

Add-ons using the default add-on icon show 32x32px on both list and details views, where they should be 48 and 64px.
I assume the add-on you are looking at still specifies a 32x32 pixel icon for iconURL. My test extension with different icons still shows a 48x48 pixel icon in the list view.
Whiteboard: [WFM?]
(Reporter)

Comment 2

8 years ago
This is about the default icon (the icon you see when you don't specify an icon)
Ah, right. So on all platforms we still have 32x32 pixel default icons for the list view:

http://mxr.mozilla.org/mozilla-central/find?string=extensionGeneric.png&tree=mozilla-central&hint=

Requesting an update from UX.
Keywords: uiwanted
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [WFM?]
So, we need icons for....

* extension
* theme
* locale
* plugin

In 48x48, and 64x64. For Windows, Windows Aero, OSX, and Linux.
(In reply to comment #0)
> Created attachment 511863 [details]
> screenshot
> 
> Add-ons using the default add-on icon show 32x32px on both list and details
> views, where they should be 48 and 64px.

All icons, default and non, should be displaying at 32x32 in list view and 64x64 in detailed view.  This wfm on the nightlies... Fligtar, you're currently getting icons as big as 48x48 in list view, as in the screenshot?
Jennifer, per default we are showing 48x48px icons in the list view if specified by an extension. That's what we also have been documented on MDN.
(Reporter)

Comment 8

8 years ago
We agreed on 48x48 for list views and 64 details views. Your mocks reflect that.
(Reporter)

Comment 9

8 years ago
(In reply to comment #5)
> All icons, default and non, should be displaying at 32x32 in list view and
> 64x64 in detailed view.  This wfm on the nightlies... Fligtar, you're currently
> getting icons as big as 48x48 in list view, as in the screenshot?

Also, are you sure you're getting 64x64 in details view? Mine are 32x32 still.
(In reply to comment #9)
> Also, are you sure you're getting 64x64 in details view? Mine are 32x32 still.

Haven't we solved this already on bug 633641?
(Reporter)

Comment 11

8 years ago
(In reply to comment #10)
> (In reply to comment #9)
> > Also, are you sure you're getting 64x64 in details view? Mine are 32x32 still.
> 
> Haven't we solved this already on bug 633641?

not for default icons, which is what this bug is about.
The problem is that when add-ons don't provide custom icons we use the default icons for all the types. And we only have 32x32px sized versions of those.
Summary: Default add-on icons still use 32x32px → Need 48x48 and 64x64 sized versions of the default add-on icons
We'd talked about icon sizes a few months ago, and we were looking then at 48x48 sized icons in list view.  That previous design is reflected in this mockup:

http://jboriss.files.wordpress.com/2010/12/1_total_manager.png

However, in early January I proposed several polish changes to the add-ons manager.  Included in that was shrinking the overall size and information in list view, and using 32x32 rather than 48x48 icons.  These changes are being tracked in meta bug 623250, and the mockups since then have reflected the 32x32 size icons.  So, this is the current mockup with 32x32 icons.

https://bug623250.bugzilla.mozilla.org/attachment.cgi?id=501343

I did not file a bug over icons changing to 32x32 because I saw 32x32 reflected in the nightlies - which I see now.  Perhaps that should have been made more explicit, and what I was seeing was us only displaying the icons we had available (as Dave points out in Comment 12) rather than implementing the mockups.

I'm still advocating for the use of 32x32 icons.  Especially with the recent polish changes that have diminished the vertical height of add-on entries in list view, 48x48 is now too big for the space provided in the manager.
(we still need 64x64 sized versions of the default add-on icons)
(In reply to comment #13)
> We'd talked about icon sizes a few months ago, and we were looking then at
> 48x48 sized icons in list view.  That previous design is reflected in this
> mockup:
> 
> http://jboriss.files.wordpress.com/2010/12/1_total_manager.png
> 
> However, in early January I proposed several polish changes to the add-ons
> manager.  Included in that was shrinking the overall size and information in
> list view, and using 32x32 rather than 48x48 icons.  These changes are being
> tracked in meta bug 623250, and the mockups since then have reflected the 32x32
> size icons.  So, this is the current mockup with 32x32 icons.
> 
> https://bug623250.bugzilla.mozilla.org/attachment.cgi?id=501343
> 
> I did not file a bug over icons changing to 32x32 because I saw 32x32 reflected
> in the nightlies - which I see now.  Perhaps that should have been made more
> explicit, and what I was seeing was us only displaying the icons we had
> available (as Dave points out in Comment 12) rather than implementing the
> mockups.
> 
> I'm still advocating for the use of 32x32 icons.  Especially with the recent
> polish changes that have diminished the vertical height of add-on entries in
> list view, 48x48 is now too big for the space provided in the manager.

I was never aware that you had talked about switching back to 32x32 icons and had I been so I would have said that it wasn't really possible at that point as we had already told add-on developers to start switching to 48x48 icons. The current list view displays 48x48 icons ok for me, if not better than 32x32.
Created attachment 513627 [details]
Mockup: Why 32x32 icons are important in the polished design, and 48x48 icons will clutter it

(In reply to comment #15)
> (In reply to comment #13)
> I was never aware that you had talked about switching back to 32x32 icons and
> had I been so I would have said that it wasn't really possible at that point as
> we had already told add-on developers to start switching to 48x48 icons. The
> current list view displays 48x48 icons ok for me, if not better than 32x32.
I can see I should have been far more explicit about this point.  Blair's amazing polish patch resulted in 32x32 icons displaying in list view, so I (wrongly) assumed that he had implemented that change.  

Maybe I can try and show why the smaller sizes with the smaller vertical height is important.

The screenshot which fligtar attached shows a large gap between the add-on title and its author.  This creates not only strange gaps in the center of add-on entries, but also groups an add-on title visually to the description of the previous add-on.  Literally, the closest text to the add-on title is not the same add-on.  This creates a pane where text seems to be spaced arbitrarily, with gaps corresponding to icons rather than visual grouping. 

The intended design (center of attached image) uses margins and whitespace to both group add-on's information together, but also to visually separate it from other entries.  The smaller icons are important, as they create the correct margin and preserve a large visual border around each item.

At the bottom of the attachment is an image showing that even 48x48 icons with the intended design (no spaces between title and description) does not work, but rather creates a visually cluttered and heavy left side of the manager.
Created attachment 513628 [details]
Screenshot: OSX add-ons manager right now

The attached in a screenshot of the add-ons manager right now on my machine, showing 32x32 icons as it has for the past month or so.  With a few spacing and margin adjustments, this is going to be fabulous.  It's unfortunate that we told add-on authors to prepare 48x48 icons only for the add-on manager, and something I take full responsibility for because I should have been more explicit about the icon change when I showed the polished mockups in early January.  But now our option is to make the design of the manager worse in order to work in that extra icon and invalidate some of the great polish work we've done so late, or to do the design we think is best with the icons we *already have*, and perhaps use those 48x48 icons elsewhere in the future.  

I feel for add-on authors who made an extra icon, and if an apology is needed I'm more than happy to write  it.  But I hope they'll understand that the best design possible is even more important than making sure our design doesn't change to become better where possible.
Created attachment 513629 [details]
screenshot

Not sure why fligtars looks so spaced out, mine looks fine.

Here is the problem. We told add-on developers that they could move to using 48x48 pixel icons. We cannot go back on that days before the last beta. So the question is, if all add-on developers move to 48x48 icons will the default icons look stupid and puny?
(In reply to comment #18)
> Created attachment 513629 [details]
> screenshot
> 
> Not sure why fligtars looks so spaced out, mine looks fine.
> 
> Here is the problem. We told add-on developers that they could move to using
> 48x48 pixel icons. We cannot go back on that days before the last beta. So the
> question is, if all add-on developers move to 48x48 icons will the default
> icons look stupid and puny?

It sounds like we're saying we should go with a worse design in the add-on manager because we told add-on developers one thing and are now saying another.  I agree that this sucks as policy, but perhaps we could explain what happened and use those 48x48 icons elsewhere.  Yes, differently sized icons will look bad in the manager, and only 48x48 icons will make the new polished design not work.  

If we can use 32x32 icons by default, I'll do whatever it takes to be the only one who looks bad.

I noticed that the current AMO icons are all 48x48.  Doesn't this mean that we are using the larger icons in a visible way akready?  Maybe we can give faster reviews to the developers who got these icons only in prep for ffx 4?
Actually, scratch that... AMO appears to be using 32x32 icons after all.
(In reply to comment #19)
> It sounds like we're saying we should go with a worse design in the add-on
> manager because we told add-on developers one thing and are now saying another.
>  I agree that this sucks as policy, but perhaps we could explain what happened
> and use those 48x48 icons elsewhere.  Yes, differently sized icons will look
> bad in the manager, and only 48x48 icons will make the new polished design not
> work.  
> 
> If we can use 32x32 icons by default, I'll do whatever it takes to be the only
> one who looks bad.

This isn't about who looks bad. Not only do I not want to waste extension developers' time any more this far past API freeze but we decided as a group the new sizes we'd use in the design after lengthy discussion and as a result code changes were made to support it and AMO designs and dev tools were made to accommodate it. We can't just change our minds on that now.

We already support displaying 48px icons and add-ons are starting to change. As that number increases our default icons are going to look out of place so please can we get 48x48 and 64x64 sized default icons for extension, theme, locale and plugin.
(In reply to comment #21)
> (In reply to comment #19)
> > It sounds like we're saying we should go with a worse design in the add-on
> > manager because we told add-on developers one thing and are now saying another.
> >  I agree that this sucks as policy, but perhaps we could explain what happened
> > and use those 48x48 icons elsewhere.  Yes, differently sized icons will look
> > bad in the manager, and only 48x48 icons will make the new polished design not
> > work.  
> > 
> > If we can use 32x32 icons by default, I'll do whatever it takes to be the only
> > one who looks bad.
> 
> This isn't about who looks bad. Not only do I not want to waste extension
> developers' time any more this far past API freeze but we decided as a group
> the new sizes we'd use in the design after lengthy discussion and as a result
> code changes were made to support it and AMO designs and dev tools were made to
> accommodate it. We can't just change our minds on that now.
> 
> We already support displaying 48px icons and add-ons are starting to change. As
> that number increases our default icons are going to look out of place so
> please can we get 48x48 and 64x64 sized default icons for extension, theme,
> locale and plugin.

You're right that this is a change - it changed when many polish changes were added in early January.  I realize (now more than ever) it's more substantial than the other changes I recommended because it involves add-on developers, but what I don't understand is why we can't just leave the icons as they are right now in the nightlies.  They're 32x32, which is great, and some padding adjustments will make it awesome.  If we go to 48x48 now, it will make the design worse and have to be corrected in Firefox 5.

I'll post all the requested icon sizes to this bug, because getting artifacts shouldn't be the issue here.
Created attachment 516466 [details]
Graphic file: OSX 64x64 puzzle piece icon
Can we get these icons made please? We'd like to start using them soon.
I just realised that as well as the puzzle piece we'll also need 48px and 64px versions of the generic dictionary, locale, plugin and theme icons to complete the look.
Is this still an issue? There is now a scalable chrome://mozapps/skin/extensions/extensionGeneric.svg

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.