Closed Bug 633703 Opened 9 years ago Closed 7 years ago

intermittent failure in layout/reftests/transform/abspos-1a.html and abspos-1b.html and abspos-1c.html and abspos-1d.html

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jfkthame, Unassigned)

References

Details

(Keywords: intermittent-failure)

(Filing this under Layout for now, though it might be Graphics?)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297489747.1297490313.23357.gz

s: talos-r3-leopard-018
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/transform/abspos-1c.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/transform/abspos-1d.html | image comparison (==)

Seems to be a slight positioning discrepancy in the first line of text. Possibly related to pixel rounding, somewhere?

Note that two earlier failures in abspos-1d.html:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297478698.1297479277.9055.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297475384.1297476289.28275.gz
were marked as being fixed by changeset 44d893bbb66d; however, the instance here occurred a few pushes later.
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1297484536.1297485279.2776.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test reftest on 2011/02/11 20:22:16
s: talos-r3-snow-045
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/transform/abspos-1b.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/transform/abspos-1c.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/transform/abspos-1d.html | image comparison (==)

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1297660562.1297661302.12939.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test reftest on 2011/02/13 21:16:02
s: talos-r3-snow-006
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/transform/abspos-1d.html | image comparison (==)
Blocks: 438871
Summary: intermittent failure in layout/reftests/transform/abspos-1[c,d].html → intermittent failure in layout/reftests/transform/abspos-1b.html and abspos-1c.html and abspos-1d.html
Whiteboard: [orange]
I knew I should have put 1a in yesterday, despite it not having won the random lottery yet.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297731182.1297731771.28891.gzRev3 MacOSX Leopard 10.5.8 mozilla-central opt test reftest on 2011/02/14 16:53:02
s: talos-r3-leopard-049
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/transform/abspos-1a.html | image comparison (==)
Summary: intermittent failure in layout/reftests/transform/abspos-1b.html and abspos-1c.html and abspos-1d.html → intermittent failure in layout/reftests/transform/abspos-1a.html and abspos-1b.html and abspos-1c.html and abspos-1d.html
Duplicate of this bug: 634143
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.