Closed Bug 633707 Opened 10 years ago Closed 5 years ago

Closing last tab of a group from multiple groups switches automatically to the next group

Categories

(Firefox Graveyard :: Panorama, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ro_nini, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

If I have multiple groups of tabs in Panorama, and while working with one group I close the last tab, most of the time it switches automatically to the next group (opens all of the tabs from the next group).
It may be important to note that I have changed the setting "browser.tabs.closeWindowWithLastTab" from about:config to "false".

Reproducible: Sometimes

Steps to Reproduce:
1. Open multiple tabs and split them in two groups (in panorama);
2. Switch to one group;
3. Start closing all tabs from this group;
4. On the last closed tab, firefox automatically switches to the next group
Actual Results:  
On the last closed tab, firefox automatically switches to the next group

Expected Results:  
Firefox should stay on the current group (with a blank single tab). Previously to panorama, when having a single last tab and closing it would leave you with a blank tab. This is what I expect to happen in panorama as well.

It may be important to note that I have changed the setting "browser.tabs.closeWindowWithLastTab" from about:config to "false" (I like to "purge" the last tab by closing it and replacing it with a blank one - in a single click).
Version: unspecified → Trunk
This sounds nice, but won't be tackled till post Fx4.

Note that you can get part of the behavior you want if you have app tabs. e.g. when you close the last tab in a group it will move you to an app tab, but if you hit "new tab" (ctrl/cmd + t) it will put you back in the your group.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Target Milestone: --- → Future
Depends on: 654311
Duplicate of this bug: 649979
Blocks: 660175
Target Milestone: Future → Firefox 7
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
OS: Windows 7 → All
Hardware: x86 → All
Target Milestone: Firefox 7 → ---
Attached patch patch v1Splinter Review
Attachment #565837 - Flags: feedback?(dao)
Comment on attachment 565837 [details] [diff] [review]
patch v1

I'm ambivalent about this. The hidden pref refers to windows, not groups, so it's unclear whether it should apply to them.
Attachment #565837 - Flags: feedback?(dao)
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.