Add-ons "Loading ..." notification has very noticeable blurred / badly anti-aliased corners.

VERIFIED FIXED in mozilla2.0b12

Status

()

Toolkit
Add-ons Manager
--
trivial
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Matt Beale, Assigned: dao)

Tracking

Trunk
mozilla2.0b12
x86_64
Windows 7
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

The bottom-right corner of the initial "Loading ..." notification on the new Add-ons manager for Firefox 4.0 beta 11 (and older betas, probably all betas) is very noticeable blurred / of lower quality compared to the other corners. The top-right corner is of a similar quality, but it isn't as jarring to look at as the bottom-right.

For clarification, this is the notification that appears when you first open the Add-ons manager while it loads the "What are Add-ons" page with the Featured / Top Add-ons.

Reproducible: Always

Steps to Reproduce:
1. Open Add-ons Manager
2. Look at the bottom-right corner of the Loading notification that appears while the "What are Add-ons" page loads.
3.
(Reporter)

Comment 1

8 years ago
Created attachment 511949 [details]
Screen shot of the loading notification
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: theme → add-ons.manager
Version: unspecified → Trunk
Does it also happen when you disable hardware acceleration in the advanced pane of the preferences?
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Does it also happen when you disable hardware acceleration in the advanced pane
> of the preferences?

Yes, it still happens with hardware acceleration turned off.
(Assignee)

Comment 4

8 years ago
Created attachment 512039 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #512039 - Flags: review?(bmcbride)
Comment on attachment 512039 [details] [diff] [review]
patch

Huh, I didn't know about that trick - cool :)
Attachment #512039 - Flags: review?(bmcbride) → review+
Comment on attachment 512039 [details] [diff] [review]
patch

Simple CSS fix. Makes things more pretty.
Attachment #512039 - Flags: approval2.0?
(Reporter)

Comment 7

8 years ago
I don't actually have a development environment set up to test this, so I'll just assume it looks good :)

Unless there is a way I can modify the built-in theme / make the changes in userChrome.css to see how they look?
Attachment #512039 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 8

8 years ago
http://hg.mozilla.org/mozilla-central/rev/87537a1f7e1f
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b12
Matt, could you please re-test with a todays nightly and check if it is fixed for you? Thanks.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
(Reporter)

Comment 10

8 years ago
Created attachment 513220 [details]
Border change mockup. Top left is Minefield 2010-12-17 Nightly, bottom right has had border changed to make it look less fuzzy.

Henrik, Minefield 2011-02-17 looks a lot better than Firefox 4.0 Beta 11, it's still not brilliant though. 

I think it's the drop-shadow being visible in the bottom-right which makes the lighter coloured pixels (due to the anti-aliasing) of that corner's border look out of place. They seem to stand-out for no obvious reason. Maybe I'm being too picky :)

I've attached a mock-up which shows how it looks if the border is made darker, but I'm not sure if this is something that would be easy to do within the scope of Firefox.
Given your screenshot I tend to say we can mark it as verified fixed. Any remaining issue is probably related to hw acceleration or layout. If you think it should be fixed please file a new bug. Thanks.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.