wrong url generated in advanced serach (https://xxx.yyy.com/bugzilla3/query.cgi) - missig s from https

RESOLVED DUPLICATE of bug 594231

Status

()

RESOLVED DUPLICATE of bug 594231
8 years ago
8 years ago

People

(Reporter: sp, Unassigned)

Tracking

3.6.3
x86_64
Linux

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: bugzilla version 3.6.3.0-2

reports->search->advanced search->search: the s is missing from https:// in the url generated by the either of the two search buttons in the advanced seach tab while it is present in all other generated urls.

bugzilla is ssl-proxied - urlbase is set to https://xxx.yyy.com/bugzilla3/

the generted search url reads eg
http://xxx.yyy.com/bugzilla3/buglist.cgi?query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED

while it should read
https://xxx.yyy.com/bugzilla3/buglist.cgi?query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED

Reproducible: Always

Steps to Reproduce:
1.please ask me for the real external url of our installation which i will provide by email
2.get an account, log in and navigate to reports->search->advanced search
3.click search
Actual Results:  
error 404 - object not found

Expected Results:  
search result
(Reporter)

Updated

8 years ago
Summary: wrong url generated by advanced serach (https://xxx.yyy.com/bugzilla3/query.cgi) - missig s from https → wrong url generated in advanced serach (https://xxx.yyy.com/bugzilla3/query.cgi) - missig s from https

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 3.6.3
Duplicate of bug: 594231
(Reporter)

Comment 2

8 years ago
what's puzzeling me is the fact that all other urls (especially the simple-search-generated url) are perfectly ok - the issue is only related to the advanced search.
(Reporter)

Comment 3

8 years ago
before upgrading from 3.6.2 to 3.6.3 it was possible to serach for a bug number. this feature is unavailable after the upgrade - we have to manually fix the url http:// to https:// in the browser which was not neccessary in 3.6.2.

thanks for your fast reply
(Reporter)

Comment 4

8 years ago
sorry, my fault - i had modified urlbase - please forget my comment #3
You need to log in before you can comment on or make changes to this bug.