mozCurrentSampleOffset increments while computer is sleeping

VERIFIED DUPLICATE of bug 520101

Status

()

Core
Audio/Video
--
major
VERIFIED DUPLICATE of bug 520101
7 years ago
7 years ago

People

(Reporter: Grant Galitz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110212 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110212 Firefox/4.0b12pre

The mozCurrentSampleOffset function from the Mozilla audio data API increments while computer is sleeping when it clearly should not. This causes many web apps to fail to correctly determine how many samples are left in the audio buffer that have not been played yet.

Reproducible: Always

Steps to Reproduce:
1. Load a ROM into the web app
2. put your computer to sleep once the ROM loads and starts producing audio
3. wake your computer and notice a multi-second delay in the audio output.
Actual Results:  
The audio is over-buffered from mozCurrentSampleOffset incrementing when it should not.

Expected Results:  
Clear audio to not over-buffer from mozCurrentSampleOffset calculations.

Happens with http://audioscene.org/scene-files/yury/examples/piano.html as well.

Seems to be unique to Mac OS X, though can someone please double check this for other operating systems?
Might be the same problem as bug 520101.
I think this is indeed a dupe.  I've tested two different fixes, and one of them solved it for me.  See bug 520101, with patch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 520101
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.