Add a pseudo-class to access indeterminate <progress> elements

RESOLVED FIXED in mozilla6

Status

()

RESOLVED FIXED
8 years ago
12 days ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

({dev-doc-complete, html5})

Trunk
mozilla6
dev-doc-complete, html5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
According to the specs, a progress element can be indeterminate. It might be interesting to let the authors access indeterminate progress elements given that they might want to style them differently.
(Assignee)

Comment 1

8 years ago
Created attachment 512129 [details] [diff] [review]
Patch v1
Attachment #512129 - Flags: review?(jonas)
For what it's worth, this is going to conflict with the various patches in bug 	313351, and bug 598833.  I can handle merging if this lands first, I guess, but just wanted to give you a heads-up.
And wait.  Why do you need that AfterSetAttr gunk?
(Assignee)

Comment 4

8 years ago
(In reply to comment #3)
> And wait.  Why do you need that AfterSetAttr gunk?

Eh, I don't indeed: indeterminate state only depends on one attribute's value. This should make the merge issue smaller. Thanks for the noticing ;)
(Assignee)

Comment 5

8 years ago
Created attachment 512147 [details] [diff] [review]
Patch v1.1

Updated patch. Boris, you won the right to review it :)
Attachment #512129 - Attachment is obsolete: true
Attachment #512147 - Flags: review?(bzbarsky)
Attachment #512129 - Flags: review?(jonas)
Comment on attachment 512147 [details] [diff] [review]
Patch v1.1

s/determinated/determined/ and looks good.  And yeah, now you're only conflicting with code I haven't written yet.  ;)
Attachment #512147 - Flags: review?(bzbarsky) → review+
(Assignee)

Updated

8 years ago
Blocks: 598833
(Assignee)

Updated

8 years ago
Whiteboard: [can land][post-2.0]
(Assignee)

Updated

8 years ago
Whiteboard: [can land][post-2.0]
(Assignee)

Updated

8 years ago
Whiteboard: [ready to land][waits for dependencies]
(Assignee)

Updated

8 years ago
Blocks: 634088
(Assignee)

Comment 7

8 years ago
I wonder if we shouldn't use :-moz-indeterminate instead of :indeterminate here.
(Assignee)

Comment 8

8 years ago
I've open a bug against HTML specs to have it specified:
http://www.w3.org/Bugs/Public/show_bug.cgi?id=12210

Though, I should probably send an email somewhere to ask for a better specification of the indeterminate pseudo-class in CSS. I wonder if CSS3-UI couldn't simply override what Selectors say (it doesn't really say anything actually, the only specs is a Note....).
(Assignee)

Comment 9

8 years ago
David, what is your feeling about comment 7? Boris is ok to not prefix it (according to our IRC conversation).
(Assignee)

Comment 10

8 years ago
Pushed:
http://hg.mozilla.org/mozilla-central/rev/89d4c7fd4d0d
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [ready to land][waits for dependencies]
Target Milestone: --- → mozilla6
Depends on: 655860
Backed out in http://hg.mozilla.org/mozilla-central/rev/dd9ba28d2bd9 to resolve bug 655860.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

8 years ago
The regression wasn't caused by these patches. Re-landed:
http://hg.mozilla.org/mozilla-central/rev/91fa0c94e6db
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
No longer depends on: 655860
Documented:

https://developer.mozilla.org/En/CSS/:indeterminate
https://developer.mozilla.org/en/HTML/Element/progress

Also listed on Firefox 6 for developers.
Keywords: dev-doc-needed → dev-doc-complete

Comment 15

12 days ago

It looks like the :indeterminate pseudo-class is not being triggered on <progress> elements with no value.

Just try opening this page:

https://bulma.io/documentation/elements/progress/

in Firefox and then in Chrome.

In Chrome, you'll get animation for indeterminate progress bars.

In Firefox, the bars are just staying solid.

Also, when you click "inspect element" in Chrome, you'll see that the progress bar has the :indeterminate pseudo-class selected.

In Firefox, it doesn't.

Comment 16

12 days ago

Oh, I'm sorry, it looks like :indeterminate is in deed being triggered in CSS, so probably the animation isn't done quite right. I'll check it out further.

You need to log in before you can comment on or make changes to this bug.