Last Comment Bug 633942 - add debug logging for OOPP model negotiation
: add debug logging for OOPP model negotiation
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 06:48 PST by Josh Aas
Modified: 2011-07-26 08:11 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (4.85 KB, patch)
2011-02-14 06:54 PST, Josh Aas
benjamin: review+
Details | Diff | Review
fix v1.1 (4.88 KB, patch)
2011-02-14 08:46 PST, Josh Aas
no flags Details | Diff | Review

Description Josh Aas 2011-02-14 06:48:21 PST
We could use some basic logging for OOPP model negotiation.
Comment 1 Josh Aas 2011-02-14 06:54:00 PST
Created attachment 512156 [details] [diff] [review]
fix v1.0
Comment 2 Benjamin Smedberg [:bsmedberg] 2011-02-14 07:13:27 PST
Comment on attachment 512156 [details] [diff] [review]
fix v1.0

I really don't like printfs which we can't turn off. Can you hide them behind an envvar or something? r=me with that change
Comment 3 Josh Aas 2011-02-14 08:46:08 PST
Created attachment 512168 [details] [diff] [review]
fix v1.1
Comment 4 Josh Aas 2011-02-15 09:13:24 PST
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/aa5cc00bf99a
Comment 5 Josh Aas 2011-02-15 10:32:27 PST
backed out due to 64-bit mac opt orange, though it really doesn't look like this patch is to blame

http://hg.mozilla.org/mozilla-central/rev/0c91682d0629
http://hg.mozilla.org/mozilla-central/rev/51b556687380
Comment 6 Mike Beltzner [:beltzner, not reading bugmail] 2011-02-23 18:32:53 PST
Comment on attachment 512168 [details] [diff] [review]
fix v1.1

Removing approval; re-request if you think we should take this.
Comment 7 Josh Aas 2011-02-23 19:45:47 PST
I no longer think this is necessary for Firefox 4 right now, if we have further problems we can take it in a later release.
Comment 8 Benoit Girard (:BenWa) 2011-07-26 08:11:01 PDT
We already landed this part of another patch

Note You need to log in before you can comment on or make changes to this bug.