Closed Bug 633986 Opened 9 years ago Closed 9 years ago

Pref nice value, default to 1 on Android

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: dougt, Assigned: stechz)

References

Details

(Keywords: mobile, perf, Whiteboard: [has-patch])

Attachments

(2 files)

Ben Stover suggested that the nicing is not needed on the Nexus S.  I confirmed that removing the nice-ing doesn't really hurt performance when loading multiple tabs in the background.

We probably should disable the nicing on > 2.2 roms.
What's different between 2.2 and 2.3 to make nicing unnecessary?
thought you might know.
It could just be a faster CPU on the Nexus S.
as far as I know the nexus s has the same cpu as the galaxy s. does disabling nicing on that device also work well? If so, perhaps its a cpu metric we should use
I think we should consider a default nice value of 1.
* Nexus One refreshes content much faster, and remains responsive.
* Nexus S refreshes content much faster (though not as fast as 0, and 0 has no obvious responsiveness hit).
* Galaxy S == Nexus S

Let's make this into a preference, and keep it at 10 for N900, 1 for Android devices.
tracking-fennec: --- → ?
Summary: disable nice-ing on nexus s → Pref nice value, default to 1 on Android
(In reply to comment #5)
> I think we should consider a default nice value of 1.
> * Nexus One refreshes content much faster, and remains responsive.
> * Nexus S refreshes content much faster (though not as fast as 0, and 0 has no
> obvious responsiveness hit).
> * Galaxy S == Nexus S
> 
> Let's make this into a preference, and keep it at 10 for N900, 1 for Android
> devices.

what is the nexus one like with 0?
> what is the nexus one like with 0?

Faster at refreshing content, but not nearly as responsive.
Attachment #512244 - Flags: review?(doug.turner)
Attachment #512244 - Attachment is obsolete: true
Attachment #512244 - Flags: review?(doug.turner)
Attachment #512244 - Attachment is obsolete: false
Attachment #512244 - Flags: review?(doug.turner)
Attachment #512249 - Flags: review?(mbrubeck)
Comment on attachment 512249 [details] [diff] [review]
Mobile preferences for nice process

We should file a followup to test different values on Maemo.  Looking at bug 594121, it looks like we only looked at 0, 10, and 20.
Attachment #512249 - Flags: review?(mbrubeck) → review+
Assignee: nobody → ben
Blocks: 624444
Status: NEW → ASSIGNED
Depends on: 594121
Keywords: mobile, perf
Whiteboard: [has-patch]
Blocks: 634057
Created Bug 634057 for Maemo followup.
Comment on attachment 512244 [details] [diff] [review]
Pref nice value, default to 1 on Android

so, you moved the setting to the parent to make sure that the preference service was around at nice'ing time.... got it.

remove the assertion here.  The EnsurePrefService already asserts on null, and if the preference service doesn't support nsIPrefBranch, we are hosed in dozens of other places.
Attachment #512244 - Flags: review?(doug.turner) → review+
tracking-fennec: ? → 2.0+
Mobile push: http://hg.mozilla.org/mobile-browser/rev/e66ba9f036a0
Platform push: http://hg.mozilla.org/mozilla-central/rev/4c2962ad0a9d
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Ugh, I'm testing today with some platform patches and this doesn't seem to affect responsiveness for me anymore, but I do see some negative impacts on checkerboarding.

We need metrics badly. I'm not sure how comfortable I am landing this right now.
Oops, wrong bug :(
Verified fix on Mozilla/5.0 (Android; Linux armv71; rv:2.0b13pre) Gecko/20110317 Firefox/4.0b13pre Fennec/4.0b6pre.   dom.ipc.content.nice = 1.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.