When closing Add-on Manager you get "Ci is not defined" messages in the error console

RESOLVED DUPLICATE of bug 641045

Status

RESOLVED DUPLICATE of bug 641045
8 years ago
7 years ago

People

(Reporter: iann_bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [SmBugEvent])

(Reporter)

Description

8 years ago
Steps to reproduce:
1/ Open Add-on Manager
2/ Open Error Console
3/ Close Add-on Manager using X

Expected results
1/ No messages in error console

Actual results
1/ Following messages in error console (twice):
Error: Ci is not defined
Source File: chrome://mozapps/content/extensions/extensions.js
Line: 1788

Comment 1

8 years ago
I'm not getting this on trunk.
Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre SeaMonkey/2.1b3pre

Comment 2

8 years ago
Confirm here in a regular (i.e. not -safe-mode) Profile.

Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20110511 Firefox/4.0.1 SeaMonkey/2.1

Line 1794 in my case.

    if (!(aStateFlags & (Ci.nsIWebProgressListener.STATE_IS_NETWORK)))

Comment 3

8 years ago
Confirmed with a new Profile.
Confirmed with a new Profile & -safe-mode.

Note that you need at least one other /tab/ open in the same window as about:addons.

Updated

8 years ago
Whiteboard: [SmBugEvent]

Comment 4

7 years ago
Is this still valid?  I can't seem to reproduce this with this build:
 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120205 Firefox/13.0a1 SeaMonkey/2.10a1

Comment 5

7 years ago
See:
Bug 641045 - opening or reloading about:addons displays "Ci is not defined" error in the error console.
Bug 665322 - "Error: Ci is not defined" when navigating away from the add-on manager.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 641045
You need to log in before you can comment on or make changes to this bug.