Closed Bug 634163 Opened 9 years ago Closed 9 years ago

browser will not load pages or page content unless mouse cursor constantly moving.

Categories

(Core :: Widget: Win32, defect, critical)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 627084
Tracking Status
blocking2.0 --- -

People

(Reporter: david, Unassigned)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Can reproduce this on 2 x64 machines running both 4.0b11 and 4.0b12pre.

Upon typing a URL into the browser bar, performing a search in google or clicking links on any page - Firefox will refuse to load page content unless the mouse cursor is moving or the keyboard is being used at the same time. If the mouse cursor is static, the page loading '(wheel) Connecting...' message in the browser tab will stay static and freeze until a mouse movement is made at which point it will continue for the duration of the movement.

Same applies to loading page content, to ensure all page content is loading the mouse has to be moved constantly, otherwise images and page content will refuse to load.

A video is available.

Reproducible: Always

Steps to Reproduce:
1. Click a link on any webpage
2. Observe browser '(wheel) Connecting...' in tab freeze
3. Move mouse or hit keyboard to progress browser loading
Actual Results:  
Firefox refuses to load any browser content unless mouse or keyboard movement is present.

Expected Results:  
Should not be required.
Version: unspecified → Trunk
I can confirm this behavior.

Check attached video.

Window 7 32bit, Aero, 1/1 Direct 3d 9 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre

First observed when try to upload attachment to Bugzilla
blocking2.0: --- → ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've seen this on a 64bit Windows 7 Home Premium machine, but not on a 64bit Windows 7 Pro machine. I believe it started around 2/12 or 2/13 but I can't be certain.
I have seen this as well (Windows 7 Pro 64 bit here). Though I have seen it sporadically for at least a month. For me, it seems to happen after I have had the browser on for a long time, and a restart always fixes it. Hard to find STR for this one, as I have only seen this happen on my work computer, and not my stationary computer or my personal laptop.
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32
Can you please try:

 - turn hardware acceleration off (Options > Advanced)
 - figuring out if it happens in earlier betas
 - seeing if it happens in 3.6

Renominate once you have answers.
blocking2.0: ? → -
This bug could be related with:
Bug 627084 - UI becomes sluggish/does not redraw unless mouse is moved after long browsing sessions
Exactly the same thing as seen in the attachments happened to me.
I am running latest-trunk (4.0b13pre 2011-03-03) on Win Vista 32bit.
Flash content was affected as well as animated GIFs.
Restarting fixed the problem.
Firefox was only running for max. one hour though.
I'm fairly confident bug 641705 addressed this. That patch is in Fx 5, which is now in beta.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627084
You need to log in before you can comment on or make changes to this bug.