Closed Bug 634216 Opened 9 years ago Closed 9 years ago

Flash contents does not scroll by mouse drag

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 628872
Tracking Status
blocking2.0 --- -

People

(Reporter: alice0775, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image screenshot
Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110214 Firefox/4.0b12pre ID:20110214030347

Flash contents does not scroll by mouse drag.


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open ( http://www.sas-fan.net/kuwata_musicman/release/lyrics/lyric05.swf )
3. Right click on the Flash content. 
4. Choose Zoom(Enlarge)(拡大 in Japanese) in Flash context menu.
5. Try to scroll by mouse drag (mouse down and then move with holding mouse down.)

Actual Results:
 Flash contents does not scroll by mouse drag

Expected Results:
 Flash contents should scroll by mouse drag.


Regression window(Windows Build):
Works:
http://hg.mozilla.org/mozilla-central/rev/37290bda896d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101220 Firefox/4.0b9pre ID:20101220031836
Fails:
http://hg.mozilla.org/mozilla-central/rev/39aba38b8706
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101219 Firefox/4.0b9pre ID:20101220064914
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=37290bda896d&tochange=39aba38b8706

In local build:
Build from
39aba38b8706 : Fails
c6669ebbabf7 : Works

Suspected bug:
39aba38b8706	Jim Mathies — Bug 572417 - Release mouse capture in flash subclass after mouse events get delivered. r=bsmedberg, a=betaN.
blocking2.0: --- → ?
* This does not happen if set dom.ipc.plugins.enabled to false.
* This problem does not happen on 
Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110214 Firefox/4.0b12pre ID:20110214030347.
This will be fixed by the changes in bug 628872.
Depends on: 628872
There's a try build over there Alice if you would like to take it for a spin. I've confirmed in my local build.
Scrolling by drag is working fine with the try build.
blocking2.0: ? → -
Fixed by bug 628872
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 628872
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 628872
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.