Clicking on a menulist button does not close the menulist when it is located within a panel

RESOLVED DUPLICATE of bug 656865

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 656865
7 years ago
20 days ago

People

(Reporter: bsg, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.79 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/4.0b11 ( .NET CLR 3.5.30729; .NET4.0E)

The dropdown button after opening the dropdown menu does not close the menu when the dropdown button is clicked again.

Reproducible: Always

Steps to Reproduce:
1. open menulist
2. hit dropdown arrow
3. hit dropdown arrow again
Actual Results:  
dropdown menu does not close

Expected Results:  
dropdown menu should close
(Reporter)

Comment 1

7 years ago
This happens with Firefox 4.0b11
Ermm what Dropdown/Menulist are you talking about?
Can you attach a Screenshot showing you Issue in Safe-mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Comment 3

7 years ago
Created attachment 512800 [details]
xul file to show menulist problem

I have attached a xul file that shows the problem in FF4.0b11. You cannot close the menulist popup by clicking on the arrow or the selection box.

Comment 4

7 years ago
This only happens if the menulist is inside a panel; it's fine when it's placed outside of a panel.
Status: UNCONFIRMED → NEW
Component: General → XP Toolkit/Widgets: XUL
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → xptoolkit.xul
Summary: menulist dropdown button not working properly → Clicking on a menulist button does not close the menulist when it is located within a panel

Comment 5

7 years ago
Probably the same underlying problem as bug 602185 and bug 443155.

Comment 6

7 years ago
Ah, this is a dupe of bug 656865 (even though this bug is older, that one has more info).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 656865
Moving to Core:XUL per https://bugzilla.mozilla.org/show_bug.cgi?id=1455336
Component: XP Toolkit/Widgets: XUL → XUL
You need to log in before you can comment on or make changes to this bug.