If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Not interpreting Java Script, unable to log in

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Ed, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.18pre) Gecko/20110213 SeaMonkey/2.0.13pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.18pre) Gecko/20110213 SeaMonkey/2.0.13pre

"Sign in" button on right side does not work in SM.  "Register" button works. And after logging in with IE I can go back to SM and the rest of the site works.

I have confirmed the same problem using Linux Mint 9 Isadora and SM 2.0.12 which I have on my laptop.

The Java script for the button that does not work is:
javascript:WebForm_DoPostBackWithOptions(new%20WebForm_PostBackOptions("_ctl0:_ctl0:MainContentPlaceHolder:MainPanel:_ctl4:login:_ctl0:_ctl1",%20"",%20true,%20"SignIn",%20"",%20false,%20true))

Java installation on my Windows XP is Java 6 Update 23


Reproducible: Always

Steps to Reproduce:
1. Go to URL as listed
2. Click on the "Sign in" button
3. Nothing happens
Actual Results:  
No action

Expected Results:  
Expected to either log in successfully or get an error message that the user/password was not accepted.

The software should have logged in to the newspaper site.
(Reporter)

Updated

7 years ago
Severity: major → blocker
Does it work with Firefox 3.5.latest?
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 2

7 years ago
It works on my laptop using Linux Firefox version 3.6.13.
Does not work on my laptop using Linux SM 2.0.12
Does not work on my PC using WIN XP and SM 2.0.13pre Gecko/20110213
I do not have Firefox on my PC.
Can you try with Firefox 3.5.16, instead of 3.6?  I believe that SM 2.0 is based off the same line as that, and it'd help figure out what layer the problem is at.

Also, is there anything in the Error Console after you click the link in question?
(FWIW, I get an invalid password error with FF4b12pre, so that seems to be working.)
(Reporter)

Comment 5

7 years ago
(In reply to comment #3)
> Can you try with Firefox 3.5.16, instead of 3.6?  I believe that SM 2.0 is
> based off the same line as that, and it'd help figure out what layer the
> problem is at.
>

No, I don't have 3.5.16 on either machine.
 
> Also, is there anything in the Error Console after you click the link in
> question?

Nothing happens.  Java does not appear to open at all.
Java's not involved.  Can you install 3.5.16 to test?  You can uninstall it after, or run it from a zip.  I can't reproduce this with any FF I have around, 3.5.14 or 3.6.13.
(Reporter)

Comment 7

7 years ago
I only have one machine with FF and that is 3.6.13.  
This problem does not exist that version of FF as I pointed out above.

I have changed the 'Product' from 'Core' to SeaMonkey.  I didn't notice that it said 'Core' before today.  I thought I had set it to SeaMonkey when I filed this report.  Sorry for not proofreading.  But it still seems to be in the handling of the Java Script.
Component: JavaScript Engine → General
Product: Core → SeaMonkey
Version: 1.9.1 Branch → SeaMonkey 2.0 Branch
I used random login details and i got a wrong username/password error with Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110214 Firefox/4.0b12pre SeaMonkey/2.1b3pre

Comment 9

7 years ago
All I get is when going to that page is:

404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

I tried:
https://secure.newspaperdirect.com/epaper/AccountingLoginPrint.aspx
https://secure.newspaperdirect.com/epaper/
https://secure.newspaperdirect.com/

Please provide a working URL to test? Thanks.
Assignee: general → nobody
Severity: blocker → normal
QA Contact: general → general
(Reporter)

Comment 10

7 years ago
(In reply to comment #9)
> 
> Please provide a working URL to test? Thanks.

Try:
http://philly.newspaperdirect.com/epaper/viewer.aspx
And then select "Current User? Click here to sign in"
That should take you to the log-in page:
  https://secure.newspaperdirect.com/epaper/AccountingLoginPrint.aspx
Box that doesn't work is the "Sign In" box. 
Don't worry about any user or password.  
Cookies should be enabled.

Comment 11

7 years ago
Error: WebForm_DoPostBackWithOptions is not defined
Source file: javascript:WebForm_DoPostBackWithOptions(new%20WebForm_PostBackOptions("_ctl0:_ctl0:MainContentPlaceHolder:MainPanel:_ctl4:login:_ctl0:_ctl1",%20"",%20true,%20"SignIn",%20"",%20false,%20true))
Line: 1

Changing the user agent string from:
Mozilla/5.0 (Windows; U; Windows NT 6.1; rv:1.9.1.18pre) Gecko/20110210 Lightning/1.0b2pre SeaMonkey/2.0.13pre
to:
Mozilla/5.0 (Windows; U; Windows NT 6.1; rv:1.9.1.18pre) Gecko/20110210 Lightning/1.0b2pre Firefox/3.5.12

Allows me to get to get:
Invalid username/password. If you previously had free access and wish to continue reading the Inquirer, please sign up by clicking REGISTER under 'Subscribe Now' on the left of this page.

Conclusion bad browser sniffing by the website.

Ed: go to about:config somewhere in there right click and select New->String
Preference Name:
general.useragent.locale
Value:
Firefox/3.5.10
[OK]

You should be able to login now.
(Reporter)

Comment 12

7 years ago
Interesting.  I use PrefBar and I tried using the FF spoof with no luck.
I changed the FF spoof to:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.17pre) Gecko/20101125 SeaMonkey/2.0.13pre NOT Firefox/3.6.12

And it's now working.  Perhaps I had an error in my useragent spoof before?
I think I had: 
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101127 Firefox/4.0b8pre

RESOLVED - Subject web site fault.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.