Won't download and install themes




Networking: FTP
18 years ago
16 years ago


(Reporter: Pete Buelow, Assigned: dougt)



Firefox Tracking Flags

(Not tracked)





18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test8 i686; en-US; m18) Gecko/20001220
BuildID:    2000122008

Mozilla won't download a theme for installation on Linux behind a corporate
firewall. This worked for me on Windows just a few days prior, but I have never
gotten it working under Linux behind a firewall.

Reproducible: Always
Steps to Reproduce:
Click on any link to attempt to import a theme.

Actual Results:  Varies. Sometimes it causes Mozilla to freeze and use 100% cpu,
but most often it simply pops up a dialog box titled Downloading with that
dialog box closing immediately without actually transferring anything.

Expected Results:  It should download and import the theme.

This has been pretty consistent behavior for the last few months now. I have
never gotten it to work from my terminal at work. Now, with the knowledge that
it works for me at home, I feel that it should be noted that it doesn't work on
Linux behind my corporate firewall. Unfortunately, I haven't tested this on
Windows here at work, or on Linux at home so the firewall issue may be paramount
or just unecessary information. There used to be an issue with ftp from the
browser in general for me here at work, but that seems to be taken care of now
as sites like ftp.gnu.org which used to cause me grief now seem to work fine.
One last note. I see the same behavior when I attempt to download plugins such
as Java.

Comment 1

18 years ago
proxy problem?  assigning meta bug
Blocks: 62353

Comment 2

18 years ago
> I have never gotten it working under Linux behind a firewall.


Comment 3

18 years ago
what sort of firewall do you have?

Comment 4

18 years ago
Tested this on Windows NT 4.0 SP 5 this morning with the latest daily build
(2000122705). Doesn't work showing the same behavior as on Linux so I am
reclassfying the OS on this bug. As for what proxy/firewall it is, I can't say
just yet. It used to identify itself to intranet pages when you got a 404, but
they have changed the software in the last year or so and there are no
identifiers anymore. I am trying to hunt down the version or at least the name
for the packgage to include in the bug.
OS: Linux → All

Comment 5

18 years ago
I cannot find out what the firewall/proxy software is. My company is keeping
pretty close tabs on that information and it is no longer public (company
public) domain. Anyway, my guess, since they have just recently switched over to
Win NT web servers and Exchange for mail is that is either an MS product or a
proxy/firewall product for large companies that runs on NT. I'm sorry I can't
get more info than that.

Comment 6

18 years ago
Looks like a duplicate of Bug 61655

Comment 7

18 years ago
Definate Duplicate

*** This bug has been marked as a duplicate of 61655 ***
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
Verifying as a dup of bug 61655 - installChrome does not work through proxy.  
Copying status as blocker of meta bug 62353 over to bug 61655.

Comment 9

17 years ago
To clarify: you have a firewall, but you do not configure your proxy preferences 
(manual or auto)?

Comment 10

16 years ago
can you provide the proxy preference information I requested? It's in Prefs
under "Advanced | Proxy"

Comment 11

16 years ago
I configure the proxy by hand, so manual. However, I thought this had been closed and resolved. I don't have the same problem now and importing themes (I just tried) seems to work as expected. Just FYI. 
You need to log in before you can comment on or make changes to this bug.