Closed Bug 634377 Opened 9 years ago Closed 9 years ago

Descriptions with no Whitespace disables window panning in Addons Manager

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: tchung, Assigned: wesj)

References

()

Details

(Whiteboard: [has-patch])

Attachments

(3 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #631926 +++

If a addon has a long description, panning over to see the full description will disallow user to pan back to the left. 

See screenshot

Repro:
1) install android fennec nightly: Mozilla/5.0 (Android; Linux armv71; rv:2.0b12pre) Gecko/20110215 Firefox/4.0b12pre Fennec/4.0b5pre		
2) install addon with a long description (eg. Persona Theme: http://www.getpersonas.com/en-US/persona/356961)
3) Once installed, pan to Addons Manager and expand the description
4) pan to the left about halfway or so
5) now click an adjacent addon that has a shorter description to expand that
one
6) page shifts to screenshot, and unable to pan back over.

Expected:
- despite a long description theme, should be able to pan back to the main addons manager view

ActuaL:
- long description extensions will disallow user to pan back to the main addons view.  Need to switch to a different prefs tab or system back button to resume view.
Assignee: nobody → mark.finkle
tracking-fennec: ? → 2.0+
Assignee: mark.finkle → wjohnston
Attached patch Patch (obsolete) — Splinter Review
Not exactly sure why this fixes this, but it causes us to scroll to the correct position when you switch elements.

I think the real issue is with our defaultDragger. When you select the second element, our richlistbox size shrinks to be smaller. When you try to scroll left, the dragger says it can't scroll that direction anymore. Setting this:

http://mxr.mozilla.org/mobile-browser/source/chrome/content/input.js#599

to return {x:true, y:true} fixes this problem. I'll write a patch that addresses that tomorrow.
Attachment #514659 - Flags: review?
Attached patch Patch v2Splinter Review
This checks if the box is already scrolled away from zero in a particular direction before deciding whether we can scroll that direction. I can't think of or find anything this should break, but I'm a bit nervous there is a hack out there somewhere that will hurt us.

There is still an issue with the horizontal scrollbar showing after you scroll back. I assume that is from mozilla-central, since these are XUL scrollbars. Digging into it a bit, but I don't think it should hold up release.

I also included the word-break stuff. Apparently that throws us down a separate layout path that automatically resizes the box in these cases. Nothing to count on, but feels nicer.
Attachment #514659 - Attachment is obsolete: true
Attachment #514907 - Flags: review?(mbrubeck)
Attachment #514659 - Flags: review?
Attachment #514907 - Flags: review?(mbrubeck) → review+
Whiteboard: [has-patch]
Pushed: http://hg.mozilla.org/mobile-browser/rev/55eb906676b6
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
strange, all my descriptions for persona themes are gone in the 3/17 build.  means my original testcase is invalid.  need to figure out what happened.
wes is investigating right now if there was a regression.   fabrice doesnt think personas is at fault.

also note that other addons show their description just fine. 

fwiw, running personas 0.91
looks like a restart picked up the descriptions.  fabrice is aware of the issue, as a restart shouldn't have been needed.

Verified fix on Mozilla/5.0 (Android; Linux armv71; rv:2.0b13pre) Gecko/20110317 Firefox/4.0b13pre Fennec/4.0b6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.