Status

()

RESOLVED DUPLICATE of bug 631487
8 years ago
8 years ago

People

(Reporter: huamao20010342, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0)
Build Identifier: Bugzilla 4.0

Undefined subroutine &Math::Random::Secure::irand called at Bugzilla/Util.pm line 577, <DATA> line 522.

Reproducible: Always

Steps to Reproduce:
1.Download Bugzilla 4.0 from http://www.bugzilla.org/download/#v40
2.tar zxvf bugzilla-4.0.tar.gz
3.run ./checksetup.pl
after Error Information:
[root@BugzillaSYS bugzilla-4.0]# ./checksetup.pl 
* This is Bugzilla 4.0 on perl 5.8.8
* Running on Linux 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21 EST 2007

Checking perl modules...
Checking for               CGI.pm (v3.51)     ok: found v3.52 
Checking for           Digest-SHA (any)       ok: found v5.50 
Checking for             TimeDate (v2.21)     ok: found v2.24 
Checking for             DateTime (v0.28)     ok: found v0.66 
Checking for    DateTime-TimeZone (v0.71)     ok: found v1.28 
Checking for                  DBI (v1.41)     ok: found v1.52 
Checking for     Template-Toolkit (v2.22)     ok: found v2.22 
Checking for           Email-Send (v2.00)     ok: found v2.198 
Checking for           Email-MIME (v1.904)    ok: found v1.907 
Checking for                  URI (any)       ok: found v1.35 
Checking for       List-MoreUtils (v0.22)     ok: found v0.30 

Checking available perl DBD modules...
Checking for               DBD-Pg (v1.45)     ok: found v1.49 
Checking for            DBD-mysql (v4.00)     ok: found v4.018 
Checking for           DBD-Oracle (v1.19)     not found 

The following Perl modules are optional:
Checking for                   GD (v1.20)     ok: found v2.45 
Checking for                Chart (v2.1)      ok: found v2.4.2 
Checking for          Template-GD (any)       ok: found v1.56 
Checking for           GDTextUtil (any)       ok: found v0.86 
Checking for              GDGraph (any)       ok: found v1.44 
Checking for             XML-Twig (any)       ok: found v3.37 
Checking for           MIME-tools (v5.406)    ok: found v5.500 
Checking for          libwww-perl (any)       ok: found v2.033 
Checking for          PatchReader (v0.9.4)    ok: found v0.9.5 
Checking for            perl-ldap (any)       ok: found v0.4001 
Checking for          Authen-SASL (any)       ok: found v2.15 
Checking for           RadiusPerl (any)       ok: found v0.20 
Checking for            SOAP-Lite (v0.712)    ok: found v0.712 
Checking for             JSON-RPC (any)       ok: found v0.96 
Checking for              JSON-XS (v2.0)      ok: found v2.3 
Checking for           Test-Taint (any)       ok: found v1.04 
Checking for          HTML-Parser (v3.40)     ok: found v3.55 
Checking for        HTML-Scrubber (any)       ok: found v0.08 
Checking for Email-MIME-Attachment-Stripper (any)       ok: found v1.316 
Checking for          Email-Reply (any)       ok: found v1.202 
Checking for          TheSchwartz (any)       ok: found v1.10 
Checking for       Daemon-Generic (any)       ok: found v0.71 
Checking for             mod_perl (v1.999022) not found 
Checking for     Apache-SizeLimit (v0.93)     not found 
Prototype mismatch: sub Mouse::Util::get_linear_isa ($;$) vs none at lib/i386-linux-thread-multi/Mouse/Util.pm line 131, <DATA> line 522.
Checking for   Math-Random-Secure (v0.05)     ok: found v0.06 
Checking for          mod_headers (any)       not found 
Checking for          mod_expires (any)       not found 
Checking for              mod_env (any)       not found 
***********************************************************************
* OPTIONAL MODULES                                                    *
***********************************************************************
* Certain Perl modules are not required by Bugzilla, but by           *
* installing the latest version you gain access to additional         *
* features.                                                           *
*                                                                     *
* The optional modules you do not have installed are listed below,    *
* with the name of the feature they enable. Below that table are the  *
* commands to install each module.                                    *
***********************************************************************
*      MODULE NAME * ENABLES FEATURE(S)                               *
***********************************************************************
*         mod_perl * mod_perl                                         *
* Apache-SizeLimit * mod_perl                                         *
***********************************************************************
* APACHE MODULES                                                      *
***********************************************************************
* Normally, when Bugzilla is upgraded, all Bugzilla users have to     *
* clear their browser cache or Bugzilla will break. If you enable     *
* certain modules in your Apache configuration (usually called        *
* httpd.conf or apache2.conf) then your users will not have to clear  *
* their caches when you upgrade Bugzilla. The modules you need to     *
* enable are:                                                         *
*                                                                     *
*    mod_headers, mod_expires, mod_env                                *
*                                                                     *
***********************************************************************
COMMANDS TO INSTALL OPTIONAL MODULES:

       mod_perl: /usr/bin/perl install-module.pl mod_perl2
Apache-SizeLimit: /usr/bin/perl install-module.pl Apache2::SizeLimit


To attempt an automatic install of every required and optional module
with one command, do:

  /usr/bin/perl install-module.pl --all

Reading ./localconfig...
Undefined subroutine &Math::Random::Secure::irand called at Bugzilla/Util.pm line 577, <DATA> line 522.
[root@BugzillaSYS bugzilla-4.0]#
it looks like Math::Random::Secure has been incorrectly installed, or one of its
dependencies hasn't.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631487
You need to log in before you can comment on or make changes to this bug.