Keyboard Navigation tab vanished

RESOLVED DUPLICATE of bug 568283

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 568283
7 years ago
7 years ago

People

(Reporter: Rocco Stilo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre SeaMonkey/2.1b3pre

In Preferences->Advanced, if a select Keyboard Navigation, panel opens blank.

Reproducible: Always

Comment 1

7 years ago
It's working here. Can you start seamonkey with the -purgecaches command line switch? Or you could go to about:config and create a boolean preference called
nglayout.debug.disable_xul_cache
and set it to true.
(Reporter)

Comment 2

7 years ago
I created this boolean, set it to true and restarted. Nothing: panel is blank. Any other idea? The other tip, how can I... set this -purgecaches command line
switch?

Comment 3

7 years ago
The other thing you could do is to set
javascript.options.showInConsole = true. Logs errors in chrome files to the Error Console.
And then open the Error Console and clear it.
Then try opening the Preferences panel->Keyboard Navigation.
Then looking at the Error Console for some relevant error messages.
(Reporter)

Comment 4

7 years ago
This is already set to true. Cleared all of error Console. Pull the Keyb. nav. and I see no errors in console.
(Reporter)

Comment 5

7 years ago
However, I see this error message from Error Console when I click on Cache panel:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsICacheService.visitEntries]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: chrome://communicator/content/pref/pref-cache.js :: updateActualCacheSize :: line 151"  data: no]

I see the Cache panel, though. I don't see the KeyBoard Navigation panel, but console doesn't log any error when I click on it.

Comment 6

7 years ago
Might be a problem with our partial updates. Try downloading the latest 2.1b3pre and doing a full install.
(Reporter)

Comment 7

7 years ago
Done so, but unfortunately, nothing changed. Keyb. nav. panel is blank. If I open Console Error, nothing happens if I click on that panel. If I click on Cache, again the same error.
I've two MacBook, the 2008 and 2010 models. On both, same situation. With the latest Snow Leopard.

Comment 8

7 years ago
OK. Try starting SeaMonkey in -safe-mode
<http://kb.mozillazine.org/Safe_mode#Mac_OS_X>
(Reporter)

Comment 9

7 years ago
Nothing. Tried staring SeaMonkey with option key held down. Same situation. I've configured also Debug panel. Are there custom settings to avoid?
On the other MacBook, I've 2.0.13pre, and it's OK, panel works and it's visible.

Comment 10

7 years ago
2.1b2pre has a lot of changes compared to 2.0.13pre. Try creating a new Seamonkey 2.1 profile using the profile manager and then starting with the new profile e.g.

/Applications/SeaMonkey.app/Contents/MacOS/seamonkey-bin -p profilenamehere
Rocco, just to be sure; this is an en-US build?
(Reporter)

Comment 12

7 years ago
Yes, but I've joint it the italian langage pack.
If you try with the en-US language, and/or a build and a profile without the it language pack, does this work?
(Reporter)

Comment 14

7 years ago
Nothing.
(Reporter)

Comment 15

7 years ago
On the latest building, clicking on the pane, I get now this error within Console:

Error: undefinied entity
File s.: chrome://communicator/content/pref/pref-keynav.xul
Line: 87, Column: 7
Code s.:
      <caption label="&accessibilityBrowseWithCaret.label;"/>

Comment 16

7 years ago
I think this is a DUP of Bug 568283 / Bug 623889
See Bug 623889 Comment 20
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 568283
You need to log in before you can comment on or make changes to this bug.