"back" button in framed page skips original page

VERIFIED DUPLICATE of bug 45227

Status

VERIFIED DUPLICATE of bug 45227
18 years ago
14 years ago

People

(Reporter: vladimir.kondratiev, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22tp i686; en-US; m18) Gecko/20001219
BuildID:    2000121908

In the page http://www.doxygen.org/, there is "Graphs and Diagrams" link. When
following this link, its URL is not displayed properly (old one remains). Page
itself displayed OK. "back" button skips original page (http://www.doxygen.org/)
and returns to previous page (that was displayed before www.doxygen.org).
From "graphs and diagrams", there is a link to the "graphviz" package. When
follow this link, page is (again) displayed correctly while URL in the toolbar
is not updated. "back" button still work as if it is www.doxygen.org page.

Reproducible: Always
Steps to Reproduce:
explained in description

Actual Results:  explained in description
http://www.doxygen.org/ is actually a frameset that loads a frame from
http://www.stack.nl/~dimitri/doxygen/.  This explains why the text in the url
bar never changes (the new pages are all loaded inside the frameset).

As for the back button, this is probably a duplicate of one of the other "back
button does strange things in framesets" bugs.
Whiteboard: DUPEME
(Assignee)

Comment 2

18 years ago
updating summary to reflect the only part of this report which actually sounds
like a bug. Dupe of bug 45227

*** This bug has been marked as a duplicate of 45227 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Summary: URL in the navigation toolbar is not displayed correctly → "back" button in framed page skips original page

Comment 3

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.