If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

NS_ERROR_XPC_BAD_OP_ON_WN_PROTO when trying to open addon tab

RESOLVED WORKSFORME

Status

()

Core
XPConnect
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: gal, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Reporter)

Description

7 years ago
I can't open the addon tab any more on a tracemonkey tip build. Why don't we have test coverage for this?

JavaScript error: , line 0: uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://browser/content/tabbrowser.xml :: addTab :: line 1265"  data: no]

1600	    if(IS_SLIM_WRAPPER(obj) && !MorphSlimWrapper(cx, obj))
1601	        return Throw(NS_ERROR_XPC_BAD_OP_ON_WN_PROTO, cx);
1602	
1603	    XPCCallContext ccx(JS_CALLER, cx, obj, funobj, JSID_VOID, argc, JS_ARGV(cx, vp), vp);
1604	    XPCWrappedNative* wrapper = ccx.GetWrapper();
1605	    THROW_AND_RETURN_IF_BAD_WRAPPER(cx, wrapper);

            ^ we throw here

1606	
1607	    XPCNativeInterface* iface;
1608	    XPCNativeMember*    member;
1609	

(gdb) p wrapper
$3 = (struct XPCWrappedNative *) 0x0
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
(Reporter)

Updated

7 years ago
Keywords: qawanted, regressionwindow-wanted
Hmm, WFM in a Build built from http://hg.mozilla.org/tracemonkey/rev/641d4c7e217b on WinXP.
(Reporter)

Comment 2

7 years ago
Mhm. Can someone else verify? I deleted my profile and rebuilt but maybe its one of those days. I will try the nightly.
We do have lots of test coverage of the addons manager being opened:
http://mxr.mozilla.org/mozilla-central/search?string=about%3Aaddons&find=test
(Reporter)

Comment 4

7 years ago
Note that this only happened when I was trying to open the addons manager from about:home. Once I navigated to a different page it did open. I will check with a rm -rf clean build whether this persists.
Please renominate if we can reproduce, but for now this looks like it's WFM.
blocking2.0: ? → -
Can this be resolved?

Comment 7

4 years ago
WFM on the 07/17 Nightly. Removing QAwanted until enough details are available that QA could reproduce the issue.
Keywords: qawanted

Comment 8

4 years ago
Can anyone still reproduce this issue or should we just close it?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.