Closed Bug 634896 Opened 9 years ago Closed 9 years ago

Message sorting by subject should recognize Outlook's localized Re: and FW: marks

Categories

(Thunderbird :: Folder and Message Lists, enhancement)

x86
macOS
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 319037

People

(Reporter: heiko.selber, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7

I have received a long thread of emails (replies, forwarded) with the same subject.

Usually, replies are prefixed with "Re:" and forwarded emails are prefixed with "FW:", and FF correctly groups them together when I sort them by subject.

However, non-English versions of Microsoft Outlook prefix their replies by localized forms, e.g. "AW:" (Antwort) for reply in German, or "ODP:" (odpowiedzi) in Polish, or "WG:" (weitergeleitet) for forwarded in German.

If emails from those Outlook clients are part of an email thread, FF can't identify them as related, with the consequence that this thread disintegrates into several ones.

The thread contains a lot of "different" subject lines, like:

"Original Subject"
"AW: Original Subject"
"AW: Re: Original Subject"
"Re: AW: Original Subject"
"FW: Re: AW: Original Subject"
"Re: ODP: FW: WG: Re: AW: Original Subject"
"Re: AW: Re: AW: Re: AW: Re: AW: Re: AW: Re: AW: Original Subject"
etc.

FF groups them only so far as traversing through the leading Re's and FW's.

A message with subject "AW: Original Subject" ends up somewhere entirely else alphabetically than "Original Subject"

It would be helpful if FF were able to identify all these prefixes and ignore them. Or perhaps it should just ignore any 2- or 3-letter words followed by a colon, but this could have lots of side-effects.

In this mozillazine forum discussion, outlook was identified as the culprit, so no action was taken: http://forums.mozillazine.org/viewtopic.php?f=30&t=62942

But the way I see it, FF would greatly improve my user experience if it cold sort these emails correctly.

Concerning standard compliance:

RFC 5322 says that "Re:" MAY be prefixed in replies, but it doesn't say that "AW:" must not.

Apparently, Outlook doesn't add a "In-Reply-To:"  or "Reference:" header, which it SHOULD do, and which could be used instead of the subject.

Reproducible: Always
See https://bugzilla.mozilla.org/show_bug.cgi?id=319037 - you can add your own prefixes to whatever your locale sets by changing the hidden pref mailnews.localizedRe and rebuilding the indexes for the folder(s) in question using the properties dialog. Marking dup, which isn't quite accurate...
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 319037
(In reply to comment #1)
> See https://bugzilla.mozilla.org/show_bug.cgi?id=319037 - you can add your own
> prefixes to whatever your locale sets by changing the hidden pref
> mailnews.localizedRe and rebuilding the indexes for the folder(s) in question
> using the properties dialog. Marking dup, which isn't quite accurate...
> 
> *** This bug has been marked as a duplicate of bug 319037 ***

Yes, I can do that, but would have to do it not only for MY locale, but for ALL the locales of everybody who sends me emails.

And I work for a company with offices in a few dozen countries, so I'd have to add quite a few, whenever I receive email from a new country, and then rebuild the index...

Wouldn't it be more sensible if Mozilla already knew them and added them for me?

Thanks for the hint anyway, I'll give it a try.

BTW: Wherever I wrote FF, I meant of course TB, stupid me...
Mozilla doesn't know them all, and very few users actually need them all. 

I really wish Outlook would generate threadable messages. My understanding is that they're only broken when using a real SMTP server, not an Exchange server, but I could be wrong.
You need to log in before you can comment on or make changes to this bug.