Open Bug 634945 Opened 9 years ago Updated Last year

Firefox should register as a handler of the .webm extension

Categories

(Firefox :: Shell Integration, defect)

defect
Not set

Tracking

()

REOPENED

People

(Reporter: johnath, Unassigned)

References

Details

We don't show up as a handler for .webm, not even a "can open with", and we should.

Are there others?
Rob, this feels like your ball?
The one other we should do the same thing for as .webm is ogg (e.g. .oga, .ogg, and .ogv) which is bug 452254.

Adding ourselves as the handler for .webm when no other apps have taken it is fairly straightforward though supporting open with is a tad tricky since we have to remove ourselves on uninstall and we support side by side installs. I was thinking about this during my time off and think I can do this reasonably.

Do we want this for Firefox 4?
We categorically would not take this change for FF4.
Glad to hear it! :)
Bug 645288 will fix this in the Firefox installer on Windows.  Does Firefox itself also need a fix on Windows, or is this a dup?

Should I file a separate bug for Mac?
This is a dupe.

Mac (and Linux) will need to handle this in a different manner (using shell integration most likely).
No longer blocks: 610484
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645288
Actually, this can either be for Mac or track the work.
Blocks: 610484
Status: RESOLVED → REOPENED
Depends on: 645288
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.