Add-on Validator does not work on Firefox 4.

VERIFIED FIXED in 5.12.11

Status

defect
--
blocker
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: bugzilla, Assigned: oremj)

Tracking

unspecified
5.12.11

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre
Build Identifier: 

Not sure if this is a problem with the site or the browser. 

The Add-on validator does not work on the latest Firefox Nightly. 




Reproducible: Always

Steps to Reproduce:
Try to validate an XPI file on https://addons.mozilla.org/en-US/developers/addon/validate
Actual Results:  
nothing happens in the browser window. 

Error console reports: Error: MAXFILESIZE is not defined
Source File: https://static.addons.mozilla.net/js/developers.js
Line: 374


Expected Results:  
It should validate the xpi file
I see "BASEDIR is not defined", but yeah, it's broken.

This is getting replaced in bug 627530, which is scheduled to go live next Thursday.  Otherwise, we'll fix this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 5.12.11
Assignee: nobody → clouserw
-> oremj.  This is because js_constants.js is a 403
Assignee: clouserw → jeremy.orem+bugs
FYI, this is a dupe of bug 632023.
Severity: normal → blocker
(Assignee)

Comment 4

8 years ago

This seems to work:

> --- files/generic/httpd-app-amo/etc-httpd/conf/domains/addons.mozilla.org.remora.conf	(revision 11936)
> +++ files/generic/httpd-app-amo/etc-httpd/conf/domains/addons.mozilla.org.remora.conf	(working copy)
> @@ -35,7 +35,7 @@
>      RewriteEngine On
>  
>      RewriteCond %{REQUEST_URI} ^/_files/.*$ [OR]
> -    RewriteCond %{REQUEST_URI} \.(css|gif|ico|jpg|js|jsi18n|png|svg|woff)/?$
> +    RewriteCond %{THE_REQUEST} "^GET .*\.(css|gif|ico|jpg|js|jsi18n|png|svg|woff)/?(\?.*)? HTTP/[\d\.]*$"
>      RewriteRule . - [E=IS_CDN_REQ:true]
>  
>      RewriteCond %{HTTP_HOST} ^static.addons.mozilla.net$


Should I make the change in production?
(In reply to comment #4)
> Should I make the change in production?

Let's do it with our push tomorrow.  We can close this since it works on stage.
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> (In reply to comment #4)
> > Should I make the change in production?
> 
> Let's do it with our push tomorrow.  We can close this since it works on stage.

Can we get the redirect on trunk staging, to verify?
OS: Linux → All
Hardware: x86 → All
To be clear, I was seeing:

[12:39:00.304] GET https://addons-cdn.allizom.org/en-US/firefox/pages/js_constants.js [HTTP/1.1 403 Forbidden 52ms]
[12:39:06.214] BASEDIR is not defined @ https://addons-cdn.allizom.org/js/developers.js:419
(Assignee)

Comment 8

8 years ago
That was a typo in preview.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.