Closed Bug 634964 Opened 9 years ago Closed 9 years ago

Empty <select><option> dropdown

Categories

(Core :: HTML: Parser, defect, minor)

x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 40545

People

(Reporter: n3croman, Unassigned)

References

()

Details

User-Agent:       Opera/9.80 (Windows NT 6.1; U; en) Presto/2.7.62 Version/11.01
Build Identifier: 4.0b12pre

Consider this simple code:
(<!DOCTYPE HTML>)
<form>
    <select>
        <option value="Value in option" label="Label in option">
    </select>
</form>
in FF4 no text is shown in dropdown, in latest Opera, Chrome, Safari and IE9 RC it works. It works even in IE7 !

Reproducible: Always

Steps to Reproduce:
1. Visit the address: no text in dropdown
2. there is no 2.
3. seriously
Actual Results:  
no text in dropdown

Expected Results:  
"Label in option" in dropdown

Tested in FF4 beta 11 and latest Minefield, just in case.
This has nothing to do with the parser...  It's just a long-standing missing feature.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: option-label
You need to log in before you can comment on or make changes to this bug.