If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow multi-dimensional tags views

RESOLVED DUPLICATE of bug 531767

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 531767
7 years ago
4 years ago

People

(Reporter: 2t2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.16) Gecko/20101130 Firefox/3.5.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.16) Gecko/20101130 Firefox/3.5.16

Possibly other Mozilla products with support of bookmarks affected as well.

Bookmark tags are great stuff because one can assign a bookmark to more categories than if using directories/folders. Using directories/folders it is
possible but one has to make copies of data. This is the strong side of tag
over folders. However if to use tags as implemented currently the creation of
flat flags structure only is possible. The tags structure can arise in one 
dimension only. Directories/folders do not show this weakness!

If to enable the tag to get other tag or more tags assigned to it will be 
possible to build up two dimensional tags structures.

Tags without any other tag/tags assigned to appear at the top-level of this 
structure. Tags with other tag/tags assigned to them appear deeper in this structure. How deep the particular tag appears depends on the tags been assigned
to it.

If to use this enhancement one no need folders any more to organize the
bookmarks.

Reproducible: Always

Steps to Reproduce:
See "details".
Actual Results:  

More tags defined.
If to show them all in the bookmarks menu, a flat structure of all tags appears.

Expected Results:  

Two dimensional structure of defined tags appears.
The tags are powerful as folders/directories are.
They are even more powerful than folders, because one can assign
an item to more categories (here tags) without doubling the object.

See "details".
Confirming as a multi-dimensional" tags hiearchy enhancement to investigate.

It's hard to build these kind of stuff correctly for all users though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Enable the tag to get other tag/tags assigned to → Allow multi-dimensional tags views
(Reporter)

Comment 2

7 years ago
> It's hard to build these kind of stuff correctly for all users though.
what do you mean here exactly?
I mean guessing a classical folders-like hierarchy from tags.
Clearly just showing a multi-pane tags view is easier.
(Reporter)

Comment 4

6 years ago
(In reply to Marco Bonardo [:mak] from comment #3)
> I mean guessing a classical folders-like hierarchy from tags.
> Clearly just showing a multi-pane tags view is easier.

I am using tags for bookmarks.
All bookmarks are placed in "unsorted" or similar.
Then the bookmark menu upon its expansion shows a list of tags, 
just like all options under all other menus.

Clicking on one of such tag position in the expanded bookmark menu
shows you all bookmarks marked with this tag.

Regarding two-dimensional tags, as for me, it would be sufficient if 
after clicking on such a second level (sub-menu) list opens with
tags (sub-tags) marked with the first-level tag.
(Reporter)

Comment 5

6 years ago
(In reply to Marco Bonardo [:mak] from comment #3)
> I mean guessing a classical folders-like hierarchy from tags.
> Clearly just showing a multi-pane tags view is easier.

How can user do/achive that?
(In reply to 2t2 from comment #5)
> (In reply to Marco Bonardo [:mak] from comment #3)
> > I mean guessing a classical folders-like hierarchy from tags.
> > Clearly just showing a multi-pane tags view is easier.
> 
> How can user do/achive that?

Hard to tell, there are various theories on the Web on methods to do it but none is satisfying enough, afaict.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531767
You need to log in before you can comment on or make changes to this bug.