Status

defect
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: gkoberger, Assigned: gkoberger)

Tracking

unspecified
5.12.11
x86
macOS

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
When polling for images in the devhub that haven't been processed, there are two bugs:

1) It checks every 100 milliseconds, which is 10 times per second
2) There's a loop inside a loop, so the amount of requests doubles each time.

Between the two, the browser ends up doing thousands of requests per second per image.  Or at least, it tries to- it usually ends up freezing up and crashing first.

I put it in 5.12.11 because I have a patch and it's fairly important- after all, we don't want to be DOSing people by mistake.

Comment 1

8 years ago
To reproduce, you need multiple screenshots have not been completed. One screenshot behaves just fine.
(Assignee)

Comment 3

8 years ago
Thanks for investigating, Andy.

http://github.com/jbalogh/zamboni/commit/4e01b69
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 4

8 years ago
verified @ https://addons-next.allizom.org/en-US/developers/addon/7-khoon-maaf/edit with Greg's help.
Status: RESOLVED → VERIFIED

Comment 5

8 years ago
Posted image post-fix screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.