rumpetroll.com says old browser being used, but in fact due to websockets being turned off by default (Firefox 4 beta 8 onwards)

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Rakshith, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre

The site says "Dear aspiring Rumpetroll.
Mother frog says you're using a rather old school browser and that it doesn't mix well with our pond. We recommend installing one of the following browsers" and gives four browser download links

    Google Chrome
    Safari 4
    Firefox 4 Beta
    Opera 10.70
The link on the bottom which says "I don't care. Let me in!" doesn't work

Reproducible: Always

Steps to Reproduce:
1.go to http://rumpetroll.com/
2.A Popup Is Seen which contains the message I explained in the details section of this bug report
3.click on "I don't care. Let me in!" and to your surprise notice no response from the site.
Actual Results:  
The site first tells that the browser is not compatible with the site, and the link which says "I don't care. Let me in!" doesnt work

Expected Results:  
Ran Like it used to In older minefield builds (Still had problems then)

This could only be my problem

Comment 1

7 years ago
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre ID:20110217123853.

It would appear that the site is using Modernizr 1.5 for feature detection and for whatever reason is deeming Minefield to be unsuitable.

Can you remember when it used to work fine?
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
since I'm not an avid user of the site and its features,I could tell you probably 3-4 months ago maybe or more If only the bookmarks manager showed the date bookmarked I could be more accurate
(Reporter)

Comment 3

7 years ago
go here http://www.modernizr.com/
Tells you what your browser supports in a small column on the right. The green check marked Text are supported by the browser

Comment 4

7 years ago
The regression range for the warning message saying the Minefield is too old, is:

Last good nightly: 2010-12-08 
First bad nightly: 2010-12-09

Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=95452499f3d6&tochange=11e328a49e0a

I've just checked and the site in question uses websockets, which have been disabled in Firefox 4 beta 8 onwards as well as Opera, due to security concerns with the spec:
http://hacks.mozilla.org/2010/12/websockets-disabled-in-firefox-4/

Within the regression range is bug 616733, where websockets was disabled by default, which confirms this.

So technically the site's error message is being shown correctly, it's just the wording of it that needs to change. For example they could make the Firefox 4 link point to: http://hacks.mozilla.org/2010/12/websockets-disabled-in-firefox-4/

This is likely a resolved invalid, since it isn't a true tech evang bug (more of a site expectation management problem), but moving there for now so someone else can make the call. It may also be a case of there being lots of websockets based demos out there that have similar poor wordings, that could be resolved by making it clearer in the known issues list of Firefox 4 (or else on various dev mailing lists), that this feature didn't make it in the final version.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
OS: Windows 7 → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Hardware: x86 → All
Summary: Problems accessing the site with current version of the nightly browser → rumpetroll.com says old browser being used, but in fact due to websockets being turned off by default (Firefox 4 beta 8 onwards)
Version: Trunk → unspecified
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.