character coding not changed correctly in a frame

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: wcalee, Assigned: pierre)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-4CLE i586; en-US; m18) Gecko/20001218
BuildID:    2000121808

In the middle frame of http://www.881903.com/, the character coding is not
detected correctly and the chinese characters does not display correctly (as
shown in snapshot 1). I have set the coding in my browser to Auto-Detect (Chinese).

Reproducible: Always

Comment 1

18 years ago
http://www.881903.com/main/mainpage/hotstuff.htm
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
I don't think this is a charset related problem.
http://www.881903.com/main/mainpage/hotstuff.htm
The page shows fine after I removed style below, not sure the page is wrong or
problem in gecko.
Changed component and reassign.

<style type="text/css">
<!--
#divCont{position:absolute; clip:rect(0,180,80,0); height:10; width:180}
.clScroll{position:absolute; top:0; font-size:10pt; left:0; width:180;
visibility:hidden}
a {  text-decoration: none}
a:link {  color: #FFFFFF}
a:hover { color: #000000}
a:visited {  color: #CECECE}

-->
</style>
Assignee: nhotta → pierre
Component: Internationalization → Style System
QA Contact: teruko → chrisd

Comment 3

18 years ago
The same problem is evident in http://www.epy.gr
The main frame does not display in greek, even if I change the document encoding
to Greek. (I know the frame does not specify an encoding, but changing the
encoding from the menu should influence all frames.)

My Build: 2001010820, Win98

Comment 4

18 years ago
The Greek page issue is about generic frame charset override (probably a dup of
bug 43529). Charset can be changed if the frame is opened as a separate window.
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian

Comment 6

18 years ago
(may be off topic..)

this site also uses document.layers and document.all for navigations the
broadcasts, so N6/Mozilla won't work for this site.  (Try to listen some
programmes there!)

should i fire a new bug report for this?

Comment 7

18 years ago
on build 2001070108 win32 http://www.881903.com/ and http://www.epy.gr works for me
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.