Black box appear in right menu tab and link opened in new windows not opened

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: raul.malea, Unassigned)

Tracking

({qawanted, regression})

Trunk
x86
Windows 7
qawanted, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre

Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre ID:20110218030352

Reproducible: Always

Steps to Reproduce:
1.Clink on link or another page with more link
2.Right click on any links
3.Open this link in new window

See in screenshot attached.
Actual Results:  
New window is opend BUT web page NOT opened AND black box appear in right menu tab

Expected Results:  
New windows is opened with web page and menu bar is rendered corectly (not black boxes)

about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/1eed87fac9ce
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests

Grafică   
      
        
Descrierea adaptorului NVIDIA GeForce 8600 GT 
ID furnizor 10de
ID dispozitiv 0402
RAM pentru adaptor 512
Drivere pentru adaptor nvd3dum nvwgf2um,nvwgf2um
Versiune driver 8.17.12.6099
Dată driver 10-16-2010
Direct2D activat true
DirectWrite activat true (6.1.7600.20830, font cache n/a)
Motor de afișare WebGL Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
Accelerare GPU Windows 1/1 Direct3D 10
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Keywords: regression
See Also: → bug 589338
Whiteboard: [hardblocker?]
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Created attachment 513491 [details]
black rectangle in right tab menu and new windows not opened link

Black box is in right menu (app) tab and in new window web page not opened
(Reporter)

Comment 2

8 years ago
Confirm this bug.
See Also: → bug 546669
(Reporter)

Updated

8 years ago
Blocks: 619666
See Also: → bug 527230
Is bug 546669 a dupe? Looks like a different problem. Does turning off hardware acceleration help?

This needs to be confirmed before it can block. Juan?
blocking2.0: ? → -
Keywords: qawanted
(Reporter)

Comment 4

8 years ago
I turning off hardware acceleration. This bug persist.

Web page does not open and the black box still appears.

Perhaps bug 546669 is ONLY similar because in that bug black boxes appear around text and tab name. In my bug black boxes appear  elsewhere (see in attachment). Second, in this case, after opening a new windows, websites not loading - page is empty.
Raul, when did you start noticing this problem? Could you try checking again in safe mode, without any extensions loaded? I've been trying to reproduce the problem on a few machines, but none that use nvidia graphics cards. We'll check with a machine more similar to yours as soon as we get it, hopefully later today.
Whiteboard: [hardblocker?]
(Reporter)

Comment 6

8 years ago
In new profile with no extensions this bug not exist. 

I noticed this bug in about 2-3 days ago. It is difficult to remember exactly because I usually do not use links opened in a new window, but only in a new tab. This bug is probably caused by an incompatibility of any extensions. I guess the fault would be: Firebug, F1 by Mozilla Labs, FoxTabs, Greasemonkey scripts, Read It Later, Ubiquity, Web Developer, Adobe Reader, or others. in the coming days I will check that the extension creates this bug.
(Reporter)

Updated

8 years ago
Component: General → Extension Compatibility
See Also: → bug 635463
(Reporter)

Comment 7

8 years ago
List for my addons:

Abduction! 3.0.8
about:blank color logo 
about:me 0.5
Add-on Collector 1.2.1 [DISABLED]
Add-on Compatibility Reporter 0.7
Adobe Acrobat 10.0.1.434
Adobe Contribute Toolbar 6.0 [DISABLED]
Authorware Web Player 2004.0.0.1
Blog Comment Autofill 
British English Dictionary 1.19.1
Bugzilla Tweaks 1.6
ChatZilla 0.9.86 [DISABLED]
Console Filter 0.3.3
Console² 0.8a1
Crash Me Now! Advanced 0.3 [DISABLED]
Default 4.0b12pre [DISABLED]
Dicționar românesc de corectare ortografică. 1.10
DivX Web Player 2.0.2.039 [DISABLED]
Download from YouTube 1.1.7
Download Statusbar 0.9.7.2
DownloadHelper 4.8.1b2
DownThemAll! 2.0b5
F1 by Mozilla Labs 0.7.5
Facebook Mass Accept Requests 1.1.18
FBTest 1.7b11
FFixer 2.3.0
FileList V3 
Firebug 1.7X.0a11
Firecookie 1.1b8
Firefox 4 Menu Button with icon+(Tabs in Titlebar) 
Firefox B 1260925626
FireFTP 1.0.11
FlashGames Maximizer 3.1.3.86 [DISABLED]
FlashGot 1.2.8.2
FoxTab 1.4.1
German Dictionary 2.0.2
Google Earth Plugin 1.0.0.1
Google Shortcuts 2.1.5
Google Talk Plugin 1.9.2.0
Google Talk Plugin Video Accelerator 0.1.43.5
Google Update 1.2.183.39
GoogleTagCloudMaker 0.2.0
Grafx Bot 0.1.32 [DISABLED]
Greasefire 1.0.4 [DISABLED]
Greasemonkey 0.9.1
gTranslate 0.8
Hard blockers counter 1.0.1
IE Tab 2 (FF 3.6+) 2.12.21.1
IE Tab Plug-in 2.2.0.1
Java Deployment Toolkit 6.0.240.7 6.0.240.7
Java(TM) Platform SE 6 U24 6.0.240.7
LookItUp 1.5
Massive Extender 0.9.6 [DISABLED]
Microsoft Office 2010 14.0.4730.1010
Microsoft Office 2010 14.0.4761.1000
Microsoft® Windows Media Player Firefox Plugin 1.0.0.8
Minefield - Better Add-on Bar/Status Bar 
Movie Torrent Search Linker (for IMDB, Rotten Tomatoes and Yahoo Movies) 0.3.7.9
Mozilla QA Companion 1.2.3
Nightly Tester Tools 3.1
NoScript 2.0.9.8
NVIDIA 3D Vision 7.17.12.6099
NVIDIA 3D VISION 7.17.12.6099
Page Speed 1.10.2 [DISABLED]
Personas 1.6.1 [DISABLED]
Picasa 3.0.0.0
Power Twitter 1.60
Puppy Dogs... 1291695684 [DISABLED]
QuickTime Plug-in 7.6.9 7.6.9.0
Read It Later 2.1.1
RealJukebox NS Plugin 12.0.1.633
RealPlayer Version Plugin 12.0.1.633
RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)  12.0.1.633
RealPlayer(tm) HTML5VideoShim Plug-In (32-bit)  12.0.1.633
ReminderFox 1.9.9.2
SeoQuake 2.6.8 [DISABLED]
Shareaholic 2.2.0 [DISABLED]
Shockwave Flash 10.2.152.26
Shockwave for Director 11.5.9.620
Show Just Image 2 2.4.4
Silverlight Plug-In 4.0.60129.0
startup 0.1
StumbleUpon 3.76 [DISABLED]
Stylish 1.1
Test Pilot 1.0.3
Textarea Backup 
Ubiquity 0.6
URL Fixer 2.0.1
Userscripts Updater 
Web Developer 1.1.9
Windows Live™ Photo Gallery 15.4.3508.1109
WOT 20100908 [DISABLED]
Yahoo Application State Plugin 1.0.0.7
Yoono 7.6.2
YouTube Enhancer 2010-12-18
YSlow 2.1.0 [DISABLED]
(Reporter)

Updated

8 years ago
See Also: → bug 635457
QA Contact: general → extension.compatibility
(Reporter)

Comment 8

8 years ago
I check more addons. Perhaps this bug was generated by:

- Firebug in co-production with FoxTab
- Greasemonkey scripts
- Adobe Reader

However, after disabled and enabled this addons and deleted cache this bug not appear again.
For moment I closed this bug.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 9

8 years ago
@Raul:-
Its acutally caused by "Hardware Accelration".I dont think that its because of any extensiton but in actual in Firefox 3.9 there is no such kind of issue.
one more thing if u unceck the check box in "Option > Advance >General i.e. use hardware when available" then its does'nt display such kind of issue.
(Reporter)

Comment 10

8 years ago
Hmm. Firebug and other develepers addons is  not guilty for this bug.

For moment I don't identified addons which generated this bug.
Reopened.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 11

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110223 Firefox/4.0b13pre ID:20110223030416

Actual my addons list:

Abduction! 3.0.8
about:blank color logo 
about:me 0.5
Add-on Compatibility Reporter 0.8
Adobe Acrobat 10.0.1.434
Adobe Contribute Toolbar 6.0 [DISABLED]
Authorware Web Player 2004.0.0.1 [DISABLED]
Blog Comment Autofill 
British English Dictionary 1.19.1
Bugzilla Tweaks 1.8
Default 4.0b13pre [DISABLED]
Dicționar românesc de corectare ortografică. 1.10
Download Statusbar 0.9.7.2
DownloadHelper 4.8.1b2
DownThemAll! 2.0b5
F1 by Mozilla Labs 0.7.5
Facebook Mass Accept Requests 1.1.18 [DISABLED]
FFixer 2.3.0
FileList V3 
Firefox 4 Menu Button with icon+(Tabs in Titlebar) 
Firefox B 1260925626
FlashGames Maximizer 3.1.3.86 [DISABLED]
FlashGot 1.2.8.2
FoxTab 1.4.1
German Dictionary 2.0.2
Google Earth Plugin 1.0.0.1
Google Shortcuts 2.1.5
Google Talk Plugin 1.9.2.0
Google Talk Plugin Video Accelerator 0.1.43.5
Google Update 1.2.183.39 [DISABLED]
Greasefire 1.0.4 [DISABLED]
Greasemonkey 0.9.1
Hard blockers counter 1.0.1
IE Tab 2 (FF 3.6+) 2.12.21.1
Java Deployment Toolkit 6.0.240.7 6.0.240.7 [DISABLED]
Java(TM) Platform SE 6 U24 6.0.240.7
Microsoft Office 2010 14.0.4730.1010 [DISABLED]
Microsoft Office 2010 14.0.4761.1000 [DISABLED]
Microsoft® Windows Media Player Firefox Plugin 1.0.0.8
Minefield - Better Add-on Bar/Status Bar 
Movie Torrent Search Linker (for IMDB, Rotten Tomatoes and Yahoo Movies) 0.3.7.9
Mozilla QA Companion 1.2.3
Nightly Tester Tools 3.1
NoScript 2.0.9.8
NVIDIA 3D Vision 7.17.12.6099 [DISABLED]
NVIDIA 3D VISION 7.17.12.6099 [DISABLED]
Personas 1.6.1 [DISABLED]
Picasa 3.0.0.0 [DISABLED]
Power Twitter 1.60
Puppy Dogs... 1291695684 [DISABLED]
QuickTime Plug-in 7.6.9 7.6.9.0
Read It Later 2.1.1
RealJukebox NS Plugin 12.0.1.633 [DISABLED]
RealPlayer Version Plugin 12.0.1.633
RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)  12.0.1.633 [DISABLED]
RealPlayer(tm) HTML5VideoShim Plug-In (32-bit)  12.0.1.633
ReminderFox 1.9.9.2
Sage 1.4.9
Shockwave Flash 10.2.152.26
Shockwave for Director 11.5.9.620
Show Just Image 2 2.4.4
Silverlight Plug-In 4.0.60129.0
StumbleUpon 3.76
Stylish 1.1
Test Pilot 1.0.3
Textarea Backup 
Ubiquity 0.6 [DISABLED]
URL Fixer 2.0.1
Userscripts Updater 
Windows Live™ Photo Gallery 15.4.3508.1109 [DISABLED]
WiseStamp 2.0.5
Yahoo Application State Plugin 1.0.0.7 [DISABLED]
Yoono 7.6.2
YouTube Enhancer 2010-12-18
Does it happen in safe mode?
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 14

8 years ago
After recent more updates for more addons black box disappear and links opened in new window.
For Fx4 final version bug is fixed.
Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0 ID:20110318052756

And my addons is now:

Abduction! 3.0.10
About startup 0.1.1
about:me 0.5
about:response 0.1
Add-on Collector 2.0
Add-on Compatibility Reporter 0.8.2
AddonFox 1.1.5 [DISABLED]
Adobe Acrobat 10.0.1.434
Adobe Contribute Toolbar 6.0 [DISABLED]
Blog Comment Autofill 
British English Dictionary 1.19.1
Bugzilla Tweaks 1.8
ChatZilla 0.9.86.1
Converter 1.0.9
Crash Report Helper (Asistent raportare incidente) 1.2
Default 4.0 [DISABLED]
Dicționar românesc de corectare ortografică. 1.11
Download Statusbar 0.9.8
DownloadHelper 4.8.4
DownThemAll! 2.0.2
F1 by Mozilla Labs 0.8.2
FFixer 2.3.1
FileList V3 
fireblur 1260925626
Firefox 4 Menu Button with icon+(Tabs in Titlebar) 
Firefox B 1260925626 [DISABLED]
Flagfox 4.1.1
FlashGames Maximizer 3.1.3.86 [DISABLED]
FlashGot 1.2.8.5
FoxTab 1.4.1
German Dictionary 2.0.2
Google Earth Plugin 1.0.0.1
Google Shortcuts 2.1.6
Google Talk Plugin 1.9.2.0
Google Talk Plugin Video Accelerator 0.1.43.5
Google Update 1.2.183.39
Greasefire 1.0.4 [DISABLED]
Greasemonkey 0.9.1
Hard blockers counter 1.0.1 [DISABLED]
IE Tab 2 (FF 3.6+) 2.12.21.1
ImTranslator 4.0
Java Deployment Toolkit 6.0.240.7 6.0.240.7
Java(TM) Platform SE 6 U24 6.0.240.7
Massive Extender 0.9.6 [DISABLED]
Microsoft Office 2010 14.0.4730.1010
Microsoft Office 2010 14.0.4761.1000
Minefield - Better Add-on Bar/Status Bar  [DISABLED]
Movie Torrent Search Linker (for IMDB, Rotten Tomatoes and Yahoo Movies) 0.3.7.9
Mozilla Labs: Prospector - Home Dash 8 [DISABLED]
Mozilla QA Companion 1.2.3
MozMill Crowd 0.1.2
Nightly Tester Tools 3.1.2
NoScript 2.0.9.9
NVIDIA 3D Vision 7.17.12.6099
NVIDIA 3D VISION 7.17.12.6099
Personas 1.6.2
Picasa 3.0.0.0
Power Twitter 1.60
Prism for Firefox 1.0b4 [DISABLED]
Puppy Dogs... 1291695684 [DISABLED]
QuickTime Plug-in 7.6.9 7.6.9.0
Read It Later 2.1.1
RealJukebox NS Plugin 12.0.1.633
RealPlayer Version Plugin 12.0.1.633
RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)  12.0.1.633
RealPlayer(tm) HTML5VideoShim Plug-In (32-bit)  12.0.1.633
ReminderFox 1.9.9.3.1
Sage 1.4.10
Shockwave Flash 10.2.153.1
Shockwave for Director 11.5.9.620
Show Just Image 2 2.5.0
Silverlight Plug-In 4.0.60129.0
startup.service 0.2
Status-4-Evar 2011.03.21.22
StumbleUpon 3.81
Stylish 1.1.1
Test Pilot 1.1
TortoiseSVN Menu 0.2.5
Ubiquity 0.6 [DISABLED]
URL Fixer 2.0.1
Userscripts Updater 
Windows Live™ Photo Gallery 15.4.3508.1109
WiseStamp 2.0.10
Yahoo Application State Plugin 1.0.0.7
Yoono 7.6.2
YouTube Enhancer 2010-12-18

Marked this bug resolved.
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.