App tab changes user on restart.

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: richard, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110217 Firefox/4.0b12pre

When multiple app tabs exist containing instances of a page logged in as different users, restarting changes all app-tabs to one user.

Reproducible: Always

Steps to Reproduce:
1. Log in to Twitter with login A.
2. Pin the page as an App Tab.
3. In a new tab, log in to Twitter as a different user (user B). (I do this to have a dedicated log-in for Army of Awesome tweets).
4. Pin the second page as an App Tab.
5. Restart Minefield.
6. Note that both Twitter app tabs are logged in as user B.
Actual Results:  
One of the app tabs has changed to be a duplicate of the other.

Expected Results:  
Both app tabs should retain the functionality they had before the restart.

Comment 1

8 years ago
Does this still occur if you repeat the STR as normal tabs, rather than app tabs (with open tabs from last session set in prefs)?

Also, does Twitter actually officially support multiple simultaneous logins?
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
The behavior is the same if Twitter is open in two regular tabs.   I think it's mostly a user-expectation issue.  When you pin something as an app-tab you're marking it as something you'll expect to reuse between sessions. 

I have no idea how to determine if Twitter "officially" supports multiple simultaneous logins.  How would one go about finding out?

There appear to be stand-alone apps that do: http://mashable.com/2009/05/18/twitter-apps-manage-multiple-accounts/

I'm guessing this is a cookie handling issue, and reading through other App Tab bugs, it may be that fixing this can't happen before electrolysis.

Comment 3

8 years ago
Marking invalid; since this is due to the way that twitter stores it's current logged in session, not a bug in Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.