Embedded YouTube and some other Flash contents show outlines on clicking




7 years ago
7 years ago


(Reporter: David Hsu, Unassigned)



Firefox Tracking Flags

(Not tracked)




(2 attachments)



7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110218 Firefox/4.0b12pre

When clicking on some Flash content, outlines show up and still do after setting the browser.display.focus_ring_width to 0. 

Reproducible: Always

This is a regression between 20101023 and 20101024, changes are:


7 years ago
Keywords: regression

Comment 1

7 years ago
Created attachment 513652 [details]

Comment 2

7 years ago
Created attachment 513653 [details]
See bug 541406 (which got backed out in the range above).

The pref you mention only affects focus rings on buttons and anchors, which are not set in html.css.  See PresShell::SetPrefFocusRules.

None of this has anything to do with plug-ins per se...
Component: Plug-ins → Layout
QA Contact: plugins → layout

Comment 4

7 years ago
(In reply to comment #3)

I didn't really know which component to choose exactly, just making an assumption. Thanks.

Comment 5

7 years ago
Nobody confirming... so is the outline around plug-ins intended?
Any way to disable it?
> is the outline around plug-ins intended?


> Any way to disable it?

Yes; you could just have a user style rule overriding the UA style rule in question.

Comment 7

7 years ago
Alright... as much as I'm still confused about showing the outline around plug-ins, I suppose this is a WONTFIX then?
Last Resolved: 7 years ago
Resolution: --- → FIXED
Why is it confusing?  The plug-in has focus; it should have a focus outline just like other things that can take focus...
Resolution: FIXED → WONTFIX

Comment 9

7 years ago
I just thought that maybe showing them only when "tab" through page elements would be better than having to see them every time I click on something.

Well then, could you show me how to hide them via user styles?
Normally if you just click on it you shouldn't get a focus outline, unless the OS convention on your OS is that it should...

You can take the style rule at http://hg.mozilla.org/mozilla-central/file/1da3405c74fd/layout/style/html.css#l697, copy it into your user stylesheet, and adjust as desired.

Comment 11

7 years ago
That'll do. Thanks!

(FWIW, I do just click on it, and I'm only seeing this in Firefox.)
On mac, the default OS behavior is that if something takes the focus at all, it gets a focus outline, no matter how it was focused.

On Windows, the behavior is very different....

Comment 13

7 years ago
I don't see the behavior in other browsers though... (including Safari)
Sure; browsers don't always follow OS UI conventions.  Safari certainly violates the Mac ones in all sorts of cases.

Comment 15

7 years ago
I think you may stop trying to convince me because I still don't get why Firefox does this when nobody else does...
I'm gonna stop spamming the bug :P Thanks anyway.
You need to log in before you can comment on or make changes to this bug.