If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash (exception in XUL.DLL) trying to "save page as" to local directory

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
7 years ago
4 years ago

People

(Reporter: Bert Goff, Unassigned)

Tracking

({crash})

Trunk
x86
OS/2
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre

I tried to save the contents of the referenced URL as a file (I changed the name in the dialog box first).  Page saved sucessfully, but Firefox terminated.  *.TRP file left in the Firefox directory.
I have had similar failures on other pages and when trying to "Save Link As".
Same symptoms also previously happened with the 3.x versions of Firefox.
Happens often, but not always.

Reproducible: Sometimes

Steps to Reproduce:
1. go to page referenced
2. Select File, then Save Page As ...
3. In the dialog box, choose a directory, then enter a different file name than suggested (ok to keep file extension).
4. Click on OK
Actual Results:  
page saved, but Firefox terminates (crashes).
If I restart Firefox, it takes me back to the page I was saving.

Expected Results:  
No Crash

*.trp file says "Exception C0000005 - Access violation"
and "Filename: F:\MOZILLA\FIREFOX4.0B12\XUL.DLL"
Complete file will be attached.

about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/542b5e55d843
Build platform
target
i386-pc-os2-emx
Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.4.1 (GCC) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -pedantic -Wno-long-long -fno-strict-aliasing -Zomf -pipe -DNDEBUG -DTRIMMED -O2
g++ 	gcc version 4.4.1 (GCC) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -fno-strict-aliasing -Zomf -pipe -DNDEBUG -DTRIMMED -O2
Configure arguments

--enable-application=browser --disable-tests --disable-necko-wifi --disable-ipc --enable-optimize --disable-debug
(Reporter)

Comment 1

7 years ago
Created attachment 513660 [details]
.TRP file for this reported problem
(Reporter)

Comment 2

7 years ago
Created attachment 513661 [details]
.TRP file from a previous crash that may be same problem
(Reporter)

Comment 3

7 years ago
Created attachment 513663 [details]
.TRP file from a previous crash that may be same problem (another)

Updated

7 years ago
Keywords: crash
Version: unspecified → Trunk

Comment 4

7 years ago
Comment on attachment 513663 [details]
.TRP file from a previous crash that may be same problem (another)

Just changed the MIME type to get it viewable
Attachment #513663 - Attachment mime type: application/octet-stream → text/plain

Comment 5

7 years ago
Bert, can you set MOZ_NO_RWS=1 in your environment and try again to save Alex's page?
Also where were you saving the file to? If the root of a drive, please try saving to a subdirectory.
(Reporter)

Comment 6

7 years ago
Dave, Thanks for responding.
Just to clarify my OS level:  I am running eComStation 2.0 GA, installed on a logical partition which is addressed as the D: drive.  This is JFS file system.
I was trying to save to: https://bugzilla.mozilla.org/show_bug.cgi?id=635433 which is another logical partition on the same physical drive, HPFS file system.  So, no, it was not to the root directory.
I tried setting MOZ_NO_RWS=1 in the .cmd file that I use to start Firefox.  The failure still occurred.  I then looked in the new .TRP file and was surprised to see in the section "DLLs accessible from this process" there is an entry:
RWSCLI08    D:\ECS\DLL\RWSCLI08.DLL 
So, that looks like SET MOZ_NO_RWS=1 did nothing.

Then I put SET MOZ_NO_RWS=1 into my \CONFIG.SYS
(Reporter)

Comment 7

7 years ago
No, I was not saving to an http location; the last comment should have said "trying to save to F:\download\fonts\wp (guess I messed up a cut & paste :) )

Then I pressed ENTER by mistake before finishing the comment.  To resume:

Then I put SET MOZ_NO_RWS=1 into my \CONFIG.SYS file.  After rebooting, I have NOT been able to recreate the problem.  I tried saving the same page several time, no trouble.  I then tried downloading a couple file using "Save Link As..."; again no problems.
So, it seems there is link between my crash and Remote Workplace Server.  But RWS is documented as relating to Thunderbird, not Firefox.  What?
(Reporter)

Comment 8

7 years ago
Ignore my comment about just Thunderbird using RWS; I just reread the Firefox README and found it there also.

Comment 9

6 years ago
I had exactly the same situation with version 6 and 8. In addition it did crash even when opening Lucide.
SET MOZ_NO_RWS=1 in the CONFIG.SYS solves the problem.
Thank you!
Bert, Italo, do you still see this when using a current version or nightly build?
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.