Implement Global 'Browser' Console

RESOLVED DUPLICATE of bug 587757

Status

defect
RESOLVED DUPLICATE of bug 587757
8 years ago
10 months ago

People

(Reporter: ddahl, Assigned: ddahl)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [console-1])

(Assignee)

Description

8 years ago
We will need a modern replacement for the Error console that is more developer-ergonomic than the existing console.

A possible goal is making this a restartless addon. 

This process will also focus on breaking down the Web Console's Http listener and other bits into a more reusable library. I'm thinking we can add to the devtools Addon SDK with this.
(Assignee)

Updated

8 years ago
Assignee: nobody → ddahl
(Assignee)

Updated

8 years ago
Whiteboard: [console-1]
(Assignee)

Comment 1

8 years ago
(In reply to comment #0)
> We will need a modern replacement for the Error console that is more
> developer-ergonomic than the existing console.
> 
> A possible goal is making this a restartless addon. 

That idea has been nixed upon experimentation. This will be browser/toolkit code
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: global-console

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.