Closed Bug 635542 Opened 9 years ago Closed 9 years ago

[Regression] Navigation buttons not updated when using URL fragments

Categories

(Firefox for Android Graveyard :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mfinkle, Assigned: mfinkle)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Bug 632837 regressed the behavior of the back / forward buttons when navigating to fragmented URLs. The browser-chrome tests actually picked this up, but was lost in the noise.

The patch adds full updating back to OnLocation change messages. We don't get a networkStop when using the session, so we can't fallback to that code. Since we are doing a full update in OnLocation, we can remove the redundant full updateURI in networkStop.

Tests pass with this change. We might have a small Ts hit with this change. Reducing Ts was the purpose of bug 632837, so backing out some of it might affect Ts.
Attachment #513795 - Flags: review?(mbrubeck)
Attachment #513795 - Flags: review?(mbrubeck) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/ef94447b908e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Can you please give me a clue on how to verify this?
bugspam
Assignee: nobody → mark.finkle
You need to log in before you can comment on or make changes to this bug.