Closed Bug 635549 Opened 10 years ago Closed 7 years ago

Add support for launching JS debugger (Venkman, Firebug) before running Mochitest

Categories

(Testing :: Mochitest, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 895471

People

(Reporter: WeirdAl, Unassigned)

Details

Suppose there's a JS error involved, where the debugger needs to be loaded before any of the test files or JS modules.  (Sometimes Venkman has trouble stepping through code that loads before it does.)  It'd be really nice to have a command-line argument for runtests.py, which says "Launch the JS debugger I specify first, then load the Mochitest."

If anyone besides me wants this and is willing to review, I can write up a patch.
I don't always forward-dupe, but when I do, it's to a bug that seems to already have someone who might want to review stuff! :-)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 895471
You need to log in before you can comment on or make changes to this bug.