Closed Bug 635556 Opened 11 years ago Closed 11 years ago

Random crash [@ JSStackFrame::callObj()]

Categories

(Core :: JavaScript Engine, defect)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 634542

People

(Reporter: JasnaPaka, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-dc323a2e-60e4-4daa-8f72-342442110219 .
============================================================= 

Signature	JSStackFrame::callObj()
UUID	dc323a2e-60e4-4daa-8f72-342442110219
Time 	2011-02-19 16:06:23.615306
Uptime	13018
Last Crash	13021 seconds (3.6 hours) before submission
Install Age	25087 seconds (7.0 hours) since version was first installed.
Product	Firefox
Version	4.0b12pre
Build ID	20110219030355
Branch	2.0
OS	Windows NT
OS Version	6.0.6002 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xffffffffffff003a
User Comments	
App Notes 	Cisco VPN
AdapterVendorID: 10de, AdapterDeviceID: 0429, AdapterDriverVersion: 7.15.11.7693

0 	mozjs.dll 	JSStackFrame::callObj 	js/src/jsinterpinlines.h:480
1 	mozjs.dll 	call_trace 	js/src/jsfun.cpp:1431
2 	mozjs.dll 	js_TraceObject 	js/src/jsobj.cpp:6530
3 	mozjs.dll 	js::gc::MarkChildren 	js/src/jsgcinlines.h:289
4 	mozjs.dll 	js::gc::MarkKind 	js/src/jsgcinlines.h:579
5 	mozjs.dll 	gc_root_traversal 	js/src/jsgc.cpp:1467
6 	mozjs.dll 	js::MarkRuntime 	js/src/jsgc.cpp:1719
7 	mozjs.dll 	MarkAndSweep 	js/src/jsgc.cpp:2407
8 	mozjs.dll 	GCUntilDone 	js/src/jsgc.cpp:2750
9 	mozjs.dll 	JS_GC 	js/src/jsapi.cpp:2573
10 	xul.dll 	nsXPConnect::Collect 	js/src/xpconnect/src/nsXPConnect.cpp:405
11 	xul.dll 	nsXPConnect::GarbageCollect 	js/src/xpconnect/src/nsXPConnect.cpp:413
12 	xul.dll 	GCTimerFired 	dom/base/nsJSEnvironment.cpp:3330
13 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
14 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
15 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
16 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
17 	xul.dll 	xul.dll@0xb30793 	
18 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
19 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
20 	mozcrt19.dll 	_VEC_memzero 	
21 	xul.dll 	xul.dll@0x35ad6d 	
22 	firefox.exe 	firefox.exe@0x1bb7 	
23 	ntdll.dll 	ntdll.dll@0x9ac1 	
24 	ntdll.dll 	ntdll.dll@0x41695 	
25 	firefox.exe 	firefox.exe@0x186f 	
26 	firefox.exe 	firefox.exe@0x186f
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
This is the call_trace crash.  The new signature is caused by the diagnostic patch collecting some data before the normal crash would occur.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 634542
Crash Signature: [@ JSStackFrame::callObj()]
You need to log in before you can comment on or make changes to this bug.