All users were logged out of Bugzilla on October 13th, 2018

<slider> element causing Mozilla to crash

VERIFIED DUPLICATE of bug 40612

Status

()

--
critical
VERIFIED DUPLICATE of bug 40612
18 years ago
10 years ago

People

(Reporter: moz_user, Assigned: eric)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.4.0-test10 i686)
BuildID:    2000101015 (M18) and 2000120516 (0.6)

Mozilla will immediately crash/exit when loading a XUL window that contains a
<slider> element.

Reproducible: Always
Steps to Reproduce:
(1) Create a XUL window with the following elements:

    <scrollbar id="scid" curpos="0" maxpos="100" 
               increment="1" pageincrement="10">
      <scrollbarbutton type="decrement"/>
      <slider flex="1"/>
      <scrollbarbutton type="increment"/>
    </scrollbar>

(2) Attempt to access the XUL window

Actual Results:  Mozilla crashes/exits.

Expected Results:  Expect a window containing a scrollbar with buttons and
slider to be displayed.

If the <slider> element is removed, the xul window will be properly displayed. 
Based on that, one has to assume that it's the slider.

Comment 1

18 years ago
-> xpt
Assignee: matt → trudelle
Component: Sidebar → XP Toolkit/Widgets: XUL
Keywords: crash
QA Contact: shrir → jrgm

Comment 2

18 years ago
->evaughan
Assignee: trudelle → evaughan

Comment 3

18 years ago
->duplicate (but intended to be fixed soon)

*** This bug has been marked as a duplicate of 40612 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
-> verified (same example)
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.