Resizing the vertical split pain does not redraw message list correctly

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: bugzilla-mozilla-20000923, Assigned: sspitzer)

Tracking

({polish})

Trunk
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.6) Gecko/20001205
BuildID:    20001205

When the vertival split pain between the account list and the massages is
resize, the message list does not resize the coloumns of the messages. It does
resize the coloumn headers, but not the actual messages in the columns. Also
(probably for the same reason), the account list does not update as the split
pain is resized -- ie. if there is an entry ending in '...' and you make the
pain wider, it does not update, and stays with the '...' on the end.

Reproducible: Always
Steps to Reproduce:
Open mail/news. Select an account folder or newsgroup so there is a list of
messages on the right. Resize the vertival split between the accounts and the
message list.

Actual Results:  Messages in list keep original column widths, although column
headers resize.

Expected Results:  The messages columns should resize as the column headers do.

Updated

18 years ago
QA Contact: esther → nbaca

Comment 1

18 years ago
Confirming this on Win ME build 2000121804

Comment 2

18 years ago
*** Bug 63653 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
Agree.....I entered a duplicate of this bug as #63653 (look at it if you want
some screenshots)

Comment 4

18 years ago
Confirming on the basis of the duplicate.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Keywords: polish, ui

Comment 5

18 years ago
*** Bug 79960 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 80070 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 86855 has been marked as a duplicate of this bug. ***
*** Bug 91754 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 91333 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
Just wanted to remember that this happens on all platforms
(Linux here=
OS--> All.  This is an RDF issue that will go away when the mail folder pane 
outliner branch has landed.
OS: Windows 2000 → All
Hardware: PC → All

Updated

17 years ago
QA Contact: nbaca → olgam

Comment 12

17 years ago
Update with on the recent branch build: 2001-10-15 - I don't see exact problem,
but some.
1. On Mac OSX: smooth re-sizing of messages columns with column headers.
On Linux - it is not smooth -  messages columns are in movement when moving the
splitter, but then they take the right position and size.
On Win 2000: blinking of messages columns while moving the splitter.  Then
correct position and size.
2. On all 3 platforms: Accounts list is updated with ... and back when moving
the splitter.

Comment 13

17 years ago
This now appears to be fixed. (2001121303 on NT4.0)
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

17 years ago
Agreed. It's working on 2001121103 on Windows 2000.

Comment 15

17 years ago
Fix verified on Linux, Win2K, Mac OSX.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.