Closed Bug 635699 Opened 9 years ago Closed 9 years ago

Tabs can't be closed after visiting About:sync-log

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ioana.chiorean, Assigned: vingtetun)

Details

Attachments

(2 files)

Attached file logs
Build id: Mozilla/5.0 (Android;Linux armv7l;rv:2.0b12pre)Gecko/20110220
Firefox/4.0b12pre Fennec /4.0b6pre 
Device: HTC Desire A8181
OS: Android 2.2

Steps to reproduce:
1. Open some tabs (like 3)
2. Go to  about:sync-log -> no page displayed
3. Try to close the tabs/all tabs

Expected result:
- you should be able to close the tabs (also the about:sync-log)

Actual result:
- the about:sync-log and about: home one can't be closed

Note: 
- see attached alogcat
- see video at : http://www.youtube.com/watch?v=dQAuLyY8GC0
setting services.sync.log.appender.debugLog.enabled = true  has no influence on it.
This happen because the log file does not exist yet, this create an error: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIWebNavigation.loadURI]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://global/content/bindings/browser.xml :: loadURIWithFlags :: line 193"  data: no] 
and the front-end code give up.
Attached patch try-catch patchSplinter Review
The patch workaround such failure by try/catching the block of code where the loadURIWithFlags code is located. This won't stop the code but because I don't think we have a way to prevent all cases like that this is probably enough.
Attachment #514013 - Flags: review?(mark.finkle)
Comment on attachment 514013 [details] [diff] [review]
try-catch patch

nit: } catch(e) {
Attachment #514013 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/5a05a798c42d
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Build id: Mozilla/5.0 (Android;Linux armv7l;rv:2.0b13pre)Gecko/20110228
Firefox/4.0b13pre Fennec /4.0b6pre 

It does work as expected.
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.