about:config can only toggle a setting once when the view is sorted by "status"

RESOLVED DUPLICATE of bug 619356

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 619356
7 years ago
7 years ago

People

(Reporter: Matthew Francis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Sorting the about:config view by status is useful to see which preferences have non-default values

However, when sorted in this way the view doesn't work correctly. A boolean preference can be toggled once, and will work correctly. Toggling a second time will change the preference, but the view will not show that the change has happened. Toggling subsequent times appears to have no effect at all until the view is refreshed by a search or changing the sort criteria.

The problem does not appear using the default (by name) search order

Reproducible: Always

Steps to Reproduce:
1. Open about:config and sort the view by "status"
2. Toggle a boolean preference (e.g. mousewheel.enable_pixel_scrolling) through the context menu or by double click
3. Toggle the same preference a second time
Actual Results:  
The displayed value does not update (although the value has actually changed). Subsequent toggling of the same key appears to change neither the value nor the appearance

Expected Results:  
The preference should be able to be toggled any number of times and display the current value each time

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 619356
You need to log in before you can comment on or make changes to this bug.