IMAP partially downloaded message (with inline attachment) causes multiple UI problems

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
8 years ago
2 years ago

People

(Reporter: j.moller, Unassigned)

Tracking

({perf, testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

When downloading a new message (msg A) with an inline attachment, if the message is not fully downloaded, and is selected in the folder list, the preview pane shows the full code of the message (screenshot 1).

From there, if another (downloaded) message (msg B) is selected in the folder list, and then the partially downloaded message A selected again, the preview pane is not updated. The attachment icon from message A disappears. (screenshot 2)

double clicking on the partially downloaded message A in the folder list will open the previously selected message B in a new tab (but with correct tab title). (screenshot 3) When message A has finally finished downloading, opened tabs will change content FROM message B to message A.

I have had this happen multiple times in the last few years that I have used thunderbird. Also I have found that when you get it to display similar to screenshot 1, if you do not select a different message, even when the message has finished downloading - you will still have the full code of the message displaying, and requires a restart of TB to get the message to open properly.

I had found a thread on the support forums a while ago which seemed similar (http://getsatisfaction.com/mozilla_messaging/topics/thunderbird_wont_show_emails_with_inline_attachements_sent_from_iphone_properly) and I was just going to post there before filing a report but getsatisfaction appears to be down.



Reproducible: Didn't try

Steps to Reproduce:
I dont have a mac to test these mails, although I just got the designer to try resend the offending mail, but this time it downloaded pretty much instantly so never got the "downloading" part... Perhaps it requires slow internet at the time (regular in NZ)



In my case, the attachment has always been a PSD of a few megabytes or more.
The sender has always sent it as an inline attachment from Apple Mail on a mac (via menu > attach he says).
(Reporter)

Comment 1

8 years ago
Created attachment 514131 [details]
screenshot 1 of the problem

this is the partially downloaded message being displayed incorrectly.
see "downloading message" in bottom left and progress bar on right.
(Reporter)

Comment 2

8 years ago
Created attachment 514132 [details]
screenshot 2 of the problem

screenshot showing preview pane outdated and attachment icon gone.
still downloading in bottom left but progress bar on right is gone.
(Reporter)

Comment 3

8 years ago
Created attachment 514133 [details]
screenshot 3 of the problem

screenshot of the "opened" message showing incorrect content (from previously selected message).
Created attachment 541683 [details]
indexing issue?

I wonder if I don't see something similar too... Here is a screenshot, it appears that Thunderbird is indexing a folder (but never stop).
Vincent can you share the message ?
Julian do you still see this?
and can you supply a test message?
Whiteboard: [closeme 2012-04-25]

Comment 7

7 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-04-25]
(Reporter)

Comment 8

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Julian do you still see this?
> and can you supply a test message?

Hi Wayne,
Sorry saw your message (email) last time and meant to have a look to try get it done, but it requires 2 people to make it happen (one to send the inline attachment from apple mail etc). I've also since upgraded to Win7, so dunno if that changes anything.

Saw status change today and realised I had forgot. I could supply the messages that caused the issue in the screenshots above, but they're long since downloaded properly, and I've changed PC. I think we'd have a hard time trying to get one mid-download (when the UI weirdness appears).

Could someone mock an email with an inline attachment that takes ages to download?
(Reporter)

Comment 9

7 years ago
Hi guys,

Happened again. I have a screenshot and the saved messaged this time so I'll edit the status to unconfirmed (to hopefully) let you guys know again - sorry if that's the wrong thing to do.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 10

7 years ago
Created attachment 635228 [details]
screenshot of the message with inline attachment not displaying correctly.
(Reporter)

Comment 11

7 years ago
Message to large to attach [11.9MB], so uploaded:
http://www.massivemedia.net.nz/download/psd%20quickie.eml
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf, testcase

Comment 12

2 years ago
Is this still present in latest Thunderbird version?
Flags: needinfo?(j.moller)
Whiteboard: [closeme 2017-05-15]
(Reporter)

Comment 13

2 years ago
(In reply to Phoenix from comment #12)
> Is this still present in latest Thunderbird version?

Not sure, it was quite a hard one to reproduce!
Flags: needinfo?(j.moller)

Comment 14

2 years ago
Thanks for the reply, feel free to reopen if issue returns
Status: NEW → RESOLVED
Last Resolved: 7 years ago2 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2017-05-15]
You need to log in before you can comment on or make changes to this bug.